aboutsummaryrefslogtreecommitdiffstats
path: root/testing/micropython
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-08-03 12:46:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-08-03 12:48:14 +0000
commitf05d7396b570645b7b9e3c8067db675c2cb4da96 (patch)
treed4e87fcd814873a07c94acf5442aa5b9290a20e6 /testing/micropython
parenta7b59fce2064665f109a4a2f2c7d80530d58d40b (diff)
downloadaports-f05d7396b570645b7b9e3c8067db675c2cb4da96.tar.bz2
aports-f05d7396b570645b7b9e3c8067db675c2cb4da96.tar.xz
testing/micropython: skip ffi_callback test and cleanup
the ffi_callback will not work under PaX kernel since it tries to allocate memory which is both executable and writeable.
Diffstat (limited to 'testing/micropython')
-rw-r--r--testing/micropython/0000-unix-mpconfigport.patch4
-rw-r--r--testing/micropython/APKBUILD30
-rw-r--r--testing/micropython/python3.patch10
3 files changed, 26 insertions, 18 deletions
diff --git a/testing/micropython/0000-unix-mpconfigport.patch b/testing/micropython/0000-unix-mpconfigport.patch
index 9025694ff2..067402341d 100644
--- a/testing/micropython/0000-unix-mpconfigport.patch
+++ b/testing/micropython/0000-unix-mpconfigport.patch
@@ -1,5 +1,5 @@
---- old/micropython-1.9.1/unix/mpconfigport.mk
-+++ new/micropython-1.9.1/unix/mpconfigport.mk
+--- micropython-1.9.1/unix/mpconfigport.mk
++++ micropython-1.9.1/unix/mpconfigport.mk
@@ -9,7 +9,7 @@
MICROPY_USE_READLINE = 1
diff --git a/testing/micropython/APKBUILD b/testing/micropython/APKBUILD
index fb7b141623..cd003b4e4a 100644
--- a/testing/micropython/APKBUILD
+++ b/testing/micropython/APKBUILD
@@ -8,37 +8,35 @@ url="http://www.micropython.org/"
arch="all"
license="MIT"
depends=""
-makedepends="libffi-dev python3"
+makedepends="libffi-dev python3 python2"
subpackages=""
source="${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz
- 0000-unix-mpconfigport.patch"
-builddir="${srcdir}/${pkgname}-${pkgver}/unix"
-
-prepare() {
- cd "${srcdir}"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+ 0000-unix-mpconfigport.patch
+ python3.patch
+ "
+builddir="${srcdir}/${pkgname}-${pkgver}"
build() {
cd "$builddir"
unset CFLAGS
- make
+ make -C unix #PYTHON=python3
}
check() {
cd "$builddir"
- make test
+
+ # ffi callback fails on kernel with PaX
+ rm tests/unix/ffi_callback.py
+
+ make -C unix test #PYTHON=python3
}
package() {
cd "$builddir"
mkdir -p "${pkgdir}/usr/bin"
- install -m755 micropython "${pkgdir}/usr/bin/micropython"
+ install -m755 unix/micropython "${pkgdir}/usr/bin/micropython"
}
sha512sums="bc0eeb1e6d821034b7157613f2d421df304f2959e9fd62d2886641eba8d74575787861c9ff46fc3bcb9c14c6ad1f698043231801207f946af9b5d302bb253c63 micropython-1.9.1.tar.gz
-926515a76dc856192de79a7c35c390bd533a38a2c163812ce5a3739280ca33881791f3d199922edb2e577ec9ac16265dc4891ad96f6c6eb4e7cf9d5ae8044a32 0000-unix-mpconfigport.patch"
+a9f922627db7cb59f56798f850c024382adffa1d1b5ccc27597ae34a9be53983a573e6dab64db4376ab24733624ad2005e67d96265517fb303d5b56f1b2654ea 0000-unix-mpconfigport.patch
+66ca172a6e9f4866e733e6c9303882dbb5f5729ffc685e0ba200010bacb8d5014527efd82da4c2ab62266e0816917758ae8e6089fb575ec31c3dc4441909343f python3.patch"
diff --git a/testing/micropython/python3.patch b/testing/micropython/python3.patch
new file mode 100644
index 0000000000..ca269d39c3
--- /dev/null
+++ b/testing/micropython/python3.patch
@@ -0,0 +1,10 @@
+diff --git a/tools/make-frozen.py b/tools/make-frozen.py
+index 1051b52..06ee7a3 100755
+--- a/tools/make-frozen.py
++++ b/tools/make-frozen.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # Create frozen modules structure for MicroPython.
+ #