aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mongo-c-driver
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2018-03-03 11:47:42 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-07 10:10:02 +0000
commit7e56c0aaff074e90cb6ab207d9c9a0bb8b40441b (patch)
tree700bf34ca4d5052654ab5091ea1a58e48921c7f3 /testing/mongo-c-driver
parent5c78920497d3a069c5200ec1f528bb7999cf2c82 (diff)
downloadaports-7e56c0aaff074e90cb6ab207d9c9a0bb8b40441b.tar.bz2
aports-7e56c0aaff074e90cb6ab207d9c9a0bb8b40441b.tar.xz
testing/mongo-c-driver: build manual pages
Diffstat (limited to 'testing/mongo-c-driver')
-rw-r--r--testing/mongo-c-driver/APKBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/testing/mongo-c-driver/APKBUILD b/testing/mongo-c-driver/APKBUILD
index 69867da24c..55bb76308b 100644
--- a/testing/mongo-c-driver/APKBUILD
+++ b/testing/mongo-c-driver/APKBUILD
@@ -1,30 +1,38 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=mongo-c-driver
pkgver=1.9.2
-pkgrel=0
+pkgrel=1
pkgdesc="Client library written in C for MongoDB"
url="https://github.com/mongodb/mongo-c-driver"
arch="all"
license="Apache-2.0"
-makedepends="$depends_dev autoconf automake libbson-dev libtool"
-options="!check" # requires a local running db instance
+depends=
+depends_dev="libressl-dev snappy-dev zlib-dev"
+makedepends="$depends_dev autoconf automake libbson-dev libtool py3-sphinx"
+install=
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/mongodb/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/mongodb/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- ./configure --prefix=/usr \
+ SPHINX_BUILD=/usr/bin/sphinx-build-3 ./configure \
+ --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info
+ --infodir=/usr/share/info \
+ --enable-man-pages=yes \
+ --enable-tests=yes \
+ --disable-automatic-init-and-cleanup \
+ --with-libbson=system \
+ --with-zlib=system
make
}
check() {
cd "$builddir"
- make test
+ MONGOC_TEST_SKIP_LIVE=on make check
}
package() {