aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mono
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-06-15 17:44:50 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-06-16 01:23:16 +0200
commit56de86da7ecb763a78220ea8ba4b60d32a2b4167 (patch)
treecaa70957cf2ae1456410d3e5851e3d5ba984eef8 /testing/mono
parent1676860d9316dbdf934fdd2cc1437c8c486a376c (diff)
downloadaports-56de86da7ecb763a78220ea8ba4b60d32a2b4167.tar.bz2
aports-56de86da7ecb763a78220ea8ba4b60d32a2b4167.tar.xz
testing/mono: modernize abuild
Diffstat (limited to 'testing/mono')
-rw-r--r--testing/mono/APKBUILD34
1 files changed, 13 insertions, 21 deletions
diff --git a/testing/mono/APKBUILD b/testing/mono/APKBUILD
index 37277b9a2a..75137e8726 100644
--- a/testing/mono/APKBUILD
+++ b/testing/mono/APKBUILD
@@ -12,27 +12,16 @@ license="GPL"
depends="python2"
depends_dev="zlib-dev libgdiplus-dev"
makedepends="$depends_dev python2 linux-headers paxmark autoconf automake libtool cmake"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="http://download.mono-project.com/sources/mono/mono-${pkgver/_/~}.tar.bz2
- "
-
-_builddir="$srcdir"/mono-${pkgver}
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="http://download.mono-project.com/sources/mono/mono-${pkgver/_/~}.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
+
# set the minimum arch for x86 to prevent atomic linker errors
[ "$CARCH" = "x86" ] && export CFLAGS="$CFLAGS -march=i586 -mtune=generic"
+
# autogen to fix supplied configure linker issues with make install
./autogen.sh \
--build=$CBUILD \
@@ -45,16 +34,19 @@ build() {
--disable-boehm \
--enable-parallel-mark \
--with-mcs-docs=no \
- --without-sigaltstack \
- || return 1
+ --without-sigaltstack
+
make get-monolite-latest
+
# dirty hack to set paxmark on grsec kernels
- make || paxmark -mr mono/mini/mono-sgen && make || return 1
+ make || paxmark -mr mono/mini/mono-sgen && make
}
package() {
- cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+
+ make -j1 DESTDIR="$pkgdir" install
+
# mark all bins
scanelf --nobanner "$pkgdir"/usr/bin/* | awk '{print $2}' \
| xargs paxmark -mr