aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mono
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-10-08 18:25:40 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2015-10-08 18:26:21 +0000
commit945bcf416cdd22c05e1e2b6d44a575941c2b6def (patch)
treea0c345a612482413022d1f6d0692d3c69a9891f2 /testing/mono
parent5aa88df1700263f3fdea5f039caff0c098d3d2ed (diff)
downloadaports-945bcf416cdd22c05e1e2b6d44a575941c2b6def.tar.bz2
aports-945bcf416cdd22c05e1e2b6d44a575941c2b6def.tar.xz
testing/mono: build fix for arm
sigcontext get included twice
Diffstat (limited to 'testing/mono')
-rw-r--r--testing/mono/APKBUILD10
-rw-r--r--testing/mono/arm-remove-sigcontext-include.patch15
2 files changed, 22 insertions, 3 deletions
diff --git a/testing/mono/APKBUILD b/testing/mono/APKBUILD
index 53a62ffc22..34f105683d 100644
--- a/testing/mono/APKBUILD
+++ b/testing/mono/APKBUILD
@@ -14,6 +14,7 @@ install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://download.mono-project.com/sources/mono/mono-${pkgver/_/~}.tar.bz2
assume-UTC-if-no-TZ-set.patch
+ arm-remove-sigcontext-include.patch
"
_builddir="$srcdir"/mono-${pkgver%.*}
@@ -61,8 +62,11 @@ package() {
}
md5sums="f598b60a664dfebb1a5eef3e66a9a178 mono-4.0.4.1.tar.bz2
-4a762b5e095baf78705d39fc2918fca7 assume-UTC-if-no-TZ-set.patch"
+4a762b5e095baf78705d39fc2918fca7 assume-UTC-if-no-TZ-set.patch
+81b20f045bb906dd2ea99b4153365387 arm-remove-sigcontext-include.patch"
sha256sums="ed11ed20ce5930c775af02bd41c43658bc9320f0bfd592fbb9895d95104dbcf9 mono-4.0.4.1.tar.bz2
-1be0b3ecf2949d79298f5b449b710a78610933f165fe2c10c37b84cf26383f56 assume-UTC-if-no-TZ-set.patch"
+1be0b3ecf2949d79298f5b449b710a78610933f165fe2c10c37b84cf26383f56 assume-UTC-if-no-TZ-set.patch
+5e522d89b84a450d507d05b59a496d006963260f4a953c107488cc2187df83bc arm-remove-sigcontext-include.patch"
sha512sums="2f299e97dd3014c9d221677e73e5134a0c0a5b27e479fb60aabc2b3eddedf07f525f3a74194ccbfdf8efe63d7ea72850f8ee64d6f15f51bccd5db0df6c1b3722 mono-4.0.4.1.tar.bz2
-aa294f81fb7f5815ef37ad191e41766836e95bf3e0ce2592e6da88cbb6c2e408b2e4cbd9c81d39f3e575ba3f1590dba5abe26d8b465b56d3f25e228dbb0ddf70 assume-UTC-if-no-TZ-set.patch"
+aa294f81fb7f5815ef37ad191e41766836e95bf3e0ce2592e6da88cbb6c2e408b2e4cbd9c81d39f3e575ba3f1590dba5abe26d8b465b56d3f25e228dbb0ddf70 assume-UTC-if-no-TZ-set.patch
+cc0382a1cba87fd2b76be46c6a2d28180cc489b10efe9359681fa85ce28d17e000dab0221f203f8f40a711fb6dddc3e39847cdf0a224344240a43d73971eccf8 arm-remove-sigcontext-include.patch"
diff --git a/testing/mono/arm-remove-sigcontext-include.patch b/testing/mono/arm-remove-sigcontext-include.patch
new file mode 100644
index 0000000000..2b6e28d0c6
--- /dev/null
+++ b/testing/mono/arm-remove-sigcontext-include.patch
@@ -0,0 +1,15 @@
+--- ./mono/mini/exceptions-arm.c.orig
++++ ./mono/mini/exceptions-arm.c
+@@ -13,12 +13,6 @@
+ #include <signal.h>
+ #include <string.h>
+
+-#ifndef MONO_CROSS_COMPILE
+-#ifdef HAVE_ASM_SIGCONTEXT_H
+-#include <asm/sigcontext.h>
+-#endif /* def HAVE_ASM_SIGCONTEXT_H */
+-#endif
+-
+ #ifdef HAVE_UCONTEXT_H
+ #include <ucontext.h>
+ #endif /* def HAVE_UCONTEXT_H */