aboutsummaryrefslogtreecommitdiffstats
path: root/testing/npd6
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2018-09-08 19:28:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-27 06:11:51 +0000
commitee7201f7185047c932b2da1ad92818ce55182782 (patch)
treeb7eaa560278af889157e9b6603ee8e77cf96d4af /testing/npd6
parentaefe89d2d761b2e40d8a9c32a249ee5b84b86c78 (diff)
downloadaports-ee7201f7185047c932b2da1ad92818ce55182782.tar.bz2
aports-ee7201f7185047c932b2da1ad92818ce55182782.tar.xz
testing/npd6: new aport
Diffstat (limited to 'testing/npd6')
-rw-r--r--testing/npd6/APKBUILD36
-rw-r--r--testing/npd6/npd6.confd1
-rw-r--r--testing/npd6/npd6.initd10
-rw-r--r--testing/npd6/remove-sysctl-h.patch12
4 files changed, 59 insertions, 0 deletions
diff --git a/testing/npd6/APKBUILD b/testing/npd6/APKBUILD
new file mode 100644
index 0000000000..bd3bc714f9
--- /dev/null
+++ b/testing/npd6/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=npd6
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Neighbor proxy daemon for IPv6"
+url="https://www.ipsidixit.net/"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="linux-headers"
+subpackages="$pkgname-doc $pkgname-openrc::noarch"
+options="!check" # No test suite present
+source="$pkgname-$pkgver.tar.gz::https://github.com/npd6/npd6/archive/$pkgver.tar.gz
+ remove-sysctl-h.patch
+ $pkgname.initd
+ $pkgname.confd"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+
+ rm -r "$pkgdir"/etc/init.d
+ install -Dm0755 "$srcdir"/npd6.initd "$pkgdir"/etc/init.d/npd6
+ install -Dm0644 "$srcdir"/npd6.confd "$pkgdir"/etc/conf.d/npd6
+}
+
+sha512sums="5cecbae63823f8729d6b24894e47e36d7278b2074499de7938a62e774cd41b4324611cfeb672d35b4d52ebe68c0dccc52a6a376c2b04fe62b5a2eeaadff32ca9 npd6-1.1.0.tar.gz
+a4d1c63af209d2c74ba16b4375e59048515a14711483ef1b7c32fb697d319ae4a5eb78976c9971ff2089aa67fd444ef646f578d37a81d7463071a0a1adb1ee03 remove-sysctl-h.patch
+f1251bb2735a9624ec958d5518740494b5f301da848b477eda89819b274e34ac58ae346cd09eb9395ae007eb1753e8a42155ca26cfad77e9f5ee717876163522 npd6.initd
+b2b883ab38ce5d3063e358d365a60c33e0f5603a7a4ecf2199248f75d1266dc8638e1670a46d9546c88cc3ac123f61d9a613b0607944291dc61ce540cfb5b546 npd6.confd"
diff --git a/testing/npd6/npd6.confd b/testing/npd6/npd6.confd
new file mode 100644
index 0000000000..de958444da
--- /dev/null
+++ b/testing/npd6/npd6.confd
@@ -0,0 +1 @@
+ARGS=
diff --git a/testing/npd6/npd6.initd b/testing/npd6/npd6.initd
new file mode 100644
index 0000000000..1632b4bb1e
--- /dev/null
+++ b/testing/npd6/npd6.initd
@@ -0,0 +1,10 @@
+#!/sbin/openrc-run
+
+command="/usr/bin/npd6"
+command_args="--foreground $ARGS"
+command_background=true
+pidfile="/run/npd6.pid"
+
+depend() {
+ need net
+}
diff --git a/testing/npd6/remove-sysctl-h.patch b/testing/npd6/remove-sysctl-h.patch
new file mode 100644
index 0000000000..ce462caafa
--- /dev/null
+++ b/testing/npd6/remove-sysctl-h.patch
@@ -0,0 +1,12 @@
+diff --git a/includes.h b/includes.h
+index 2b74cef69a..1cbcffdecf 100644
+--- a/includes.h
++++ b/includes.h
+@@ -53,7 +53,6 @@
+ #include <netinet/ip6.h>
+ #include <netinet/icmp6.h>
+ #include <arpa/inet.h>
+-#include <sys/sysctl.h>
+ #include <net/if.h>
+ #include <getopt.h>
+ #include <ifaddrs.h>