aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-camomile
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-07 18:19:19 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-07 18:41:29 +0200
commit431580e26f764631d14d6f1f0fc7061a1cb7d781 (patch)
tree1e9c50330e5a30988e6847da05e55e956c461186 /testing/ocaml-camomile
parentc1a4655c1c5ba63241798b9b574c2439cb244320 (diff)
downloadaports-431580e26f764631d14d6f1f0fc7061a1cb7d781.tar.bz2
aports-431580e26f764631d14d6f1f0fc7061a1cb7d781.tar.xz
testing/ocaml-camomile: upgrade to 1.0.1
Diffstat (limited to 'testing/ocaml-camomile')
-rw-r--r--testing/ocaml-camomile/APKBUILD36
1 files changed, 21 insertions, 15 deletions
diff --git a/testing/ocaml-camomile/APKBUILD b/testing/ocaml-camomile/APKBUILD
index cbb48447af..37564c785b 100644
--- a/testing/ocaml-camomile/APKBUILD
+++ b/testing/ocaml-camomile/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ocaml-camomile
_pkgname=camomile
-pkgver=0.8.7
-pkgrel=2
+pkgver=1.0.1
+pkgrel=0
pkgdesc="A Unicode library for OCaml"
url="https://github.com/yoriyuki/Camomile"
# x86, armhf, s390x: limited by ocaml aport
@@ -12,8 +12,8 @@ license="LGPL-2.0-or-later"
depends="$pkgname-data=$pkgver-r$pkgrel ocaml-runtime"
makedepends="dune ocaml ocaml-compiler-libs ocaml-cppo ocaml-findlib opam"
subpackages="$pkgname-dev $pkgname-data::noarch"
-source="$pkgname-$pkgver.tar.gz::https://github.com/yoriyuki/$_pkgname/archive/rel-$pkgver.tar.gz"
-builddir="$srcdir/Camomile-rel-$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/yoriyuki/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/Camomile-$pkgver"
build() {
cd "$builddir"
@@ -40,25 +40,31 @@ package() {
--destdir="$pkgdir/usr" \
--libdir="$pkgdir/usr/lib/ocaml"
- cd "$pkgdir"
-
- # There's just a readme.
- rm -Rf usr/doc
+ # There's just a readme and changelog.
+ rm -Rf "$pkgdir"/usr/doc
# Remove annotation files and sources.
- rm -Rf usr/lib/ocaml/$_pkgname/*.cmt*
- rm -Rf usr/lib/ocaml/$_pkgname/*.ml
+ find "$pkgdir"/usr/lib/ocaml/$_pkgname \( \
+ -name '*.cmt' -o \
+ -name '*.cmti' -o \
+ -name '*.ml' -o \
+ -name '*.ml-gen' \) -delete
}
dev() {
default_dev
depends="$pkgname=$pkgver-r$pkgrel"
- local sitelib="usr/lib/ocaml/$_pkgname"
- cd "$pkgdir"/$sitelib
+ cd "$pkgdir"
- mkdir -p "$subpkgdir"/$sitelib
- mv *.cmx *.cmxa *.mli "$subpkgdir"/$sitelib/
+ local path; for path in $(find usr/lib/ocaml/$_pkgname \
+ -name '*.cmx' -o \
+ -name '*.cmxa' -o \
+ -name '*.mli')
+ do
+ mkdir -p "${path%/*}"
+ mv "$path" "$subpkgdir"/${path%/*}/
+ done
}
data() {
@@ -69,4 +75,4 @@ data() {
mv "$pkgdir"/usr/share/$_pkgname "$subpkgdir"/usr/share/
}
-sha512sums="a8db2086030b703e1ada0e2cc195e1c6338946439b3a6b6a05febb3a0d24388add9fe06961025e043181a885bb085e33cebc8027c66c7dbbe1cc30e18df27cf2 ocaml-camomile-0.8.7.tar.gz"
+sha512sums="41c453a55d284f879e390ef341482ad5c3dccb1cfd3720fd8513555276dde2397b657c632aa9b02f12f7990adb57bd7c3add637e30606c8f9ab5d28454eddfef ocaml-camomile-1.0.1.tar.gz"