aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-result
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-05 00:38:58 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-05 00:40:36 +0100
commit8ab5ddc71cf18f0e6d6aa3f3e1166315608f3fda (patch)
tree6589800447eb97f940365496a331dfbd229ee446 /testing/ocaml-result
parent17b424dbe93716ac7aeb167c53f9c25c89531787 (diff)
downloadaports-8ab5ddc71cf18f0e6d6aa3f3e1166315608f3fda.tar.bz2
aports-8ab5ddc71cf18f0e6d6aa3f3e1166315608f3fda.tar.xz
testing/ocaml-result: new aport
https://github.com/janestreet/result Compat result type
Diffstat (limited to 'testing/ocaml-result')
-rw-r--r--testing/ocaml-result/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/testing/ocaml-result/APKBUILD b/testing/ocaml-result/APKBUILD
new file mode 100644
index 0000000000..11f775351c
--- /dev/null
+++ b/testing/ocaml-result/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ocaml-result
+_pkgname=result
+pkgver=1.3
+pkgrel=0
+pkgdesc="Compat result type"
+url="https://github.com/janestreet/result"
+arch="all !x86 !armhf !s390x" # limited by ocaml
+license="BSD-3-Clause"
+makedepends="dune ocaml ocaml-findlib opam"
+options="!check" # no tests provided
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/janestreet/$_pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ jbuilder build @install
+}
+
+package() {
+ cd "$builddir"
+
+ mkdir -p "$pkgdir"/usr/lib/ocaml
+ jbuilder install \
+ --destdir="$pkgdir/usr" \
+ --libdir="$pkgdir/usr/lib/ocaml"
+
+ cd "$pkgdir"
+
+ # Remove compiled tests.
+ rm usr/lib/ocaml/$_pkgname/*.cmt
+
+ # Move docs to proper location.
+ mkdir -p usr/share/doc
+ mv usr/doc/$_pkgname usr/share/doc/$pkgname
+ rmdir usr/doc
+}
+
+dev() {
+ depends="$pkgname=$pkgver-r$pkgrel"
+ local sitelib="usr/lib/ocaml/$_pkgname"
+
+ default_dev
+
+ cd "$pkgdir"/$sitelib
+
+ # May not be created if native compiler is N/A for this platform.
+ mkdir -p "$subpkgdir"/$sitelib
+ mv *.cmx *.cmxa *.ml "$subpkgdir"/$sitelib/ || true
+}
+
+sha512sums="eb65e5c3e122db1bb477169d83efc7e02b0c72d3ffdb0cdadf7fc92e28c4e3843d8a0ed28133641cbcb239236fa5c83144610c5de713db5c8f63d9f433d37ba9 ocaml-result-1.3.tar.gz"