aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocamlclean
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-12 00:54:58 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-12 00:55:41 +0100
commitaa1451cd338713944975240130f4bc2b3c5c88f5 (patch)
tree384d85acd3814c2b3b61c31507ca77ad4a0aa324 /testing/ocamlclean
parent08e0ea5a97ba58324cd51f7b6c91c8c91c16aaba (diff)
downloadaports-aa1451cd338713944975240130f4bc2b3c5c88f5.tar.bz2
aports-aa1451cd338713944975240130f4bc2b3c5c88f5.tar.xz
testing/ocamlclean: new aport
http://www.algo-prog.info/ocapic/web/index.php?id=OCAPIC:OCamlClean OCaml Bytecode Cleaner
Diffstat (limited to 'testing/ocamlclean')
-rw-r--r--testing/ocamlclean/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/ocamlclean/APKBUILD b/testing/ocamlclean/APKBUILD
new file mode 100644
index 0000000000..7e70ae7e62
--- /dev/null
+++ b/testing/ocamlclean/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ocamlclean
+pkgver=2.1
+pkgrel=0
+pkgdesc="OCaml Bytecode Cleaner"
+url="http://www.algo-prog.info/ocapic/web/index.php?id=OCAPIC:OCamlClean"
+arch="all !x86 !armhf !s390x" # limited by ocaml aport
+license="CECILL-2.0"
+makedepends="bash ocaml ocamlbuild"
+subpackages="$pkgname-doc"
+# backup: https://github.com/bvaugon/ocamlclean
+source="$pkgname-$pkgver.tar.bz2::http://www.algo-prog.info/ocapic/web/lib/exe/fetch.php?media=ocapic:$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ -prefix "$pkgdir/usr" \
+ -mandir "$pkgdir/usr/share/man"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install
+}
+
+sha512sums="6554f452c48c853fed4587456c582f31a47d947772975ba17e5a4cbb566fa61ed996dee23ec83fe360c7bcf65cc9f8544c78491769e8546b05dbada53b4cf73d ocamlclean-2.1.tar.bz2"