aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openssh-askpass
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-08-10 14:02:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-08-10 14:11:01 +0000
commit75b0997404b4e842477527bceffb2998f737b088 (patch)
tree1608ca78deb487abf8762190e93ad9ece0d33521 /testing/openssh-askpass
parent426066e5cafb51e0ab9217cdd206b71a1f252ec8 (diff)
downloadaports-75b0997404b4e842477527bceffb2998f737b088.tar.bz2
aports-75b0997404b4e842477527bceffb2998f737b088.tar.xz
testing/openssh-askpass: new aport
A passphrase dialog for OpenSSH and GTK http://www.openssh.org/portable.html
Diffstat (limited to 'testing/openssh-askpass')
-rw-r--r--testing/openssh-askpass/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/openssh-askpass/APKBUILD b/testing/openssh-askpass/APKBUILD
new file mode 100644
index 0000000000..43eaf06a27
--- /dev/null
+++ b/testing/openssh-askpass/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=openssh-askpass
+pkgver=6.0_p1
+_myver=${pkgver%_*}${pkgver#*_}
+pkgrel=0
+pkgdesc="A passphrase dialog for OpenSSH and GTK"
+url="http://www.openssh.org/portable.html"
+arch="all"
+license="as-is"
+depends="openssh-client"
+makedepends="gtk+2.0-dev"
+subpackages=""
+source="ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-$_myver.tar.gz
+ "
+
+_builddir="$srcdir"/openssh-$_myver/contrib
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case "$i" in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -N -i "$srcdir"/${i##*/} || return 1
+ ;;
+ esac
+ done
+}
+
+build () {
+ cd "$_builddir"
+ make gnome-ssh-askpass2
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 gnome-ssh-askpass2 "$pkgdir"/usr/lib/ssh/gtk-ssh-askpass
+ install -d "$pkgdir"/etc/profile.d
+ cat > "$pkgdir"/etc/profile.d/openssh-askpass.sh <<EOF
+SSH_ASKPASS=/usr/lib/ssh/gtk-ssh-askpass
+export SSH_ASKPASS
+EOF
+ chmod +x "$pkgdir"/etc/profile.d/openssh-askpass.sh
+}
+
+md5sums="3c9347aa67862881c5da3f3b1c08da7b openssh-6.0p1.tar.gz"