aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openssh-askpass
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-10-08 14:09:43 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2017-10-08 14:10:14 +0200
commite1eb1e96f1122253167b4e2226f6c96ff95fca7a (patch)
treefea66fc2a5ff5fbcba8bedcb9b0c1548b2a4394a /testing/openssh-askpass
parent8c704d3917bee4e41a2ee09c9cc955262459b57b (diff)
downloadaports-e1eb1e96f1122253167b4e2226f6c96ff95fca7a.tar.bz2
aports-e1eb1e96f1122253167b4e2226f6c96ff95fca7a.tar.xz
testing/openssh-askpass: move from unmaintained
Diffstat (limited to 'testing/openssh-askpass')
-rw-r--r--testing/openssh-askpass/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/openssh-askpass/APKBUILD b/testing/openssh-askpass/APKBUILD
new file mode 100644
index 0000000000..76109697ce
--- /dev/null
+++ b/testing/openssh-askpass/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=openssh-askpass
+pkgver=7.6_p1
+_myver=${pkgver%_*}${pkgver#*_}
+pkgrel=0
+pkgdesc="A passphrase dialog for OpenSSH and GTK"
+url="http://www.openssh.org/portable.html"
+arch="all"
+license="as-is"
+depends="openssh-client"
+options="!check"
+makedepends="gtk+2.0-dev"
+subpackages=""
+source="https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-$_myver.tar.gz"
+builddir="$srcdir"/openssh-$_myver/contrib
+
+build () {
+ cd "$builddir"
+ make gnome-ssh-askpass2
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 gnome-ssh-askpass2 "$pkgdir"/usr/lib/ssh/gtk-ssh-askpass
+ install -d "$pkgdir"/etc/profile.d
+ cat > "$pkgdir"/etc/profile.d/openssh-askpass.sh <<- EOF
+ SSH_ASKPASS=/usr/lib/ssh/gtk-ssh-askpass
+ export SSH_ASKPASS
+ EOF
+ chmod +x "$pkgdir"/etc/profile.d/openssh-askpass.sh
+}
+
+sha512sums="de17fdcb8239401f76740c8d689a8761802f6df94e68d953f3c70b9f4f8bdb403617c48c1d01cc8c368d88e9d50aee540bf03d5a36687dfb39dfd28d73029d72 openssh-7.6p1.tar.gz"