aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-time-duration
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-07-06 11:36:53 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-07-11 14:31:24 +0300
commitc76560164b1890c6179d195d78423dfcb782dded (patch)
tree74c67fdd1c1f4c4f3ce6a64e351b6e57b4affd06 /testing/perl-time-duration
parentca8a98d14ef7222a4006baa304b0e20972a1c5da (diff)
downloadaports-c76560164b1890c6179d195d78423dfcb782dded.tar.bz2
aports-c76560164b1890c6179d195d78423dfcb782dded.tar.xz
testing/perl-time-duration: new aport
http://search.cpan.org/dist/Time-Duration/
Diffstat (limited to 'testing/perl-time-duration')
-rw-r--r--testing/perl-time-duration/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/perl-time-duration/APKBUILD b/testing/perl-time-duration/APKBUILD
new file mode 100644
index 0000000000..ff790afa8d
--- /dev/null
+++ b/testing/perl-time-duration/APKBUILD
@@ -0,0 +1,48 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=perl-time-duration
+_pkgreal=Time-Duration
+pkgver=1.20
+pkgrel=0
+pkgdesc="rounded or exact English expression of durations"
+url="http://search.cpan.org/dist/Time-Duration/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+cpancheckdepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+checkdepends="$cpancheckdepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/N/NE/NEILB/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="74bdcbc2b65061ad30540a95467de24f552235cea2367a7770309d9ffefeb35717f438e4f7ebf6a1d63f338cd714ffe16b3f45808514995db9753d643892d5f9 Time-Duration-1.20.tar.gz"