aboutsummaryrefslogtreecommitdiffstats
path: root/testing/phoronix-test-suite
diff options
context:
space:
mode:
authorLucas Ramage <lramage@star2star.com>2017-11-05 20:12:06 -0500
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-12-15 14:05:31 +0000
commitb423b2c0499a69dab662003e81e0f8dcdf7050fe (patch)
tree7dd83b7818b27ed1a4503e47c2ecc038db650a53 /testing/phoronix-test-suite
parentcc8761a9a2849c5e5a49af8667dbea9a2aeb990d (diff)
downloadaports-b423b2c0499a69dab662003e81e0f8dcdf7050fe.tar.bz2
aports-b423b2c0499a69dab662003e81e0f8dcdf7050fe.tar.xz
testing/phoronix-test-suite
https://www.phoronix-test-suite.com The most comprehensive testing and benchmarking platform available for Linux
Diffstat (limited to 'testing/phoronix-test-suite')
-rw-r--r--testing/phoronix-test-suite/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/phoronix-test-suite/APKBUILD b/testing/phoronix-test-suite/APKBUILD
new file mode 100644
index 0000000000..b25d71310b
--- /dev/null
+++ b/testing/phoronix-test-suite/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: Lucas Ramage <ramage.lucas@openmailbox.org>
+# Maintainer: Lucas Ramage <ramage.lucas@openmailbox.org>
+pkgname=phoronix-test-suite
+pkgver=7.4.0
+pkgrel=0
+pkgdesc="The most comprehensive testing and benchmarking platform available for Linux"
+url="https://www.phoronix-test-suite.com"
+arch="noarch"
+license="GPL-3.0"
+depends="php5 php5-dom php5-zip php5-json"
+subpackages="pkgname-doc"
+provides="phoromatic-server phoromatic-client"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz"
+options="!check"
+
+package() {
+ cd $builddir
+ DESTDIR="${pkgdir}" ./install-sh
+}
+
+sha512sums="cccf4cbba87de0768640cc79e30200200a0cbbf90ab55ee43bd2493a188714cf3d979fd82990066477aae6de815baa153a2a7df9937595c9c42c0915e4e4920f phoronix-test-suite-7.4.0.tar.gz"