aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-backcall
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2018-09-15 17:00:50 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-09-17 06:36:13 +0000
commitc2b1920875df9a97ab4ad94d29b5501590495fb3 (patch)
treea3cda680dfea08ab1020c69729de0d50fd8a8231 /testing/py-backcall
parentd33a469e6b1d39760196d5d68f01ac1353f70b13 (diff)
downloadaports-c2b1920875df9a97ab4ad94d29b5501590495fb3.tar.bz2
aports-c2b1920875df9a97ab4ad94d29b5501590495fb3.tar.xz
testing/py-backcall: new aport
dependency for ipython
Diffstat (limited to 'testing/py-backcall')
-rw-r--r--testing/py-backcall/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py-backcall/APKBUILD b/testing/py-backcall/APKBUILD
new file mode 100644
index 0000000000..eca5d7396d
--- /dev/null
+++ b/testing/py-backcall/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=py-backcall
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Backwards compatible callback APIs"
+url="https://github.com/takluyver/backcall"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="python2-dev python3-dev"
+options="!check" # pytest broken on alpine
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/b/backcall/backcall-$pkgver.tar.gz"
+builddir="$srcdir/${pkgname#py-}-$pkgver"
+
+build() {
+ cd "$builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="359c483fbc8998fc2420daee2a6af7566c47fb03f64e465aa226589a2f98a4b219ab5e5b90e5f677087827a1ac658c02ec3062e9ffe9ac1ebfd9db3bb40339cd backcall-0.1.0.tar.gz"