aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-buildutils
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-03-03 12:05:52 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-03-04 09:50:15 +0000
commit617af26654919d7a3dd71e5235f34dd627b56659 (patch)
treee2d3173b176b79836e96a58b160a894a148079f3 /testing/py-buildutils
parent60afcaf7cad64bbb7a6b02b025bf3e84e41e6fc8 (diff)
downloadaports-617af26654919d7a3dd71e5235f34dd627b56659.tar.bz2
aports-617af26654919d7a3dd71e5235f34dd627b56659.tar.xz
testing/py-buildutils: license specified, add package()
Diffstat (limited to 'testing/py-buildutils')
-rw-r--r--testing/py-buildutils/APKBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/testing/py-buildutils/APKBUILD b/testing/py-buildutils/APKBUILD
index cbc08cc7a3..2ff65c319d 100644
--- a/testing/py-buildutils/APKBUILD
+++ b/testing/py-buildutils/APKBUILD
@@ -1,24 +1,30 @@
# Contributor: Andrew Manison <amanison@anselsystems.com>
-# Maintainer:
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-buildutils
_pkgname=${pkgname#py-}
pkgver=0.3
pkgrel=1
-pkgdesc="buildutils is a collection of enhancements to the Python distutils"
+pkgdesc="Buildutils is a collection of enhancements to the Python distutils"
url="http://pypi.python.org/pypi/buildutils/0.3"
-arch="all"
-license="GPL"
-depends="python py-setuptools"
-makedepends="python-dev"
-install=
+arch="noarch"
+license="MIT"
+depends="python"
+makedepends="python-dev py-setuptools"
+install=""
subpackages=""
source="http://pypi.python.org/packages/source/b/$_pkgname/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$srcdir"/$_pkgname-$pkgver
- mkdir -p "$pkgdir"/usr/lib/python2.6/site-packages
- python setup.py install --root="$pkgdir"
- echo "/usr/lib/python2.6/site-packages/$_pkgname-$pkgver-py2.6.egg" > "$pkgdir"/usr/lib/python2.6/site-packages/$_pkgname.pth
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
md5sums="fec620dee05f591edad386366b52e17b buildutils-0.3.tar.gz"
+sha256sums="8f9921cf145a1879986b4028db0af4f028f65fe6eae29936490174037ba7dfc5 buildutils-0.3.tar.gz"
+sha512sums="63e3c0e9737672abcb7f9b10909df69f93eb801eeb829f840aaabc37428fc640ed7df4232283f933e5f0bb80b0195624b1ba69aeba1b01b7a61250bf6e6b6421 buildutils-0.3.tar.gz"