aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-coreschema
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-12-29 19:31:04 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-12-29 19:32:56 +0000
commit5329d305dc883f21050056de0e83eebb3e73fbe2 (patch)
tree1dfbe22204f0eb39876be74924b98df6005a217e /testing/py-coreschema
parent14f680b47663fbb40686accdefd7aab5843a005c (diff)
downloadaports-5329d305dc883f21050056de0e83eebb3e73fbe2.tar.bz2
aports-5329d305dc883f21050056de0e83eebb3e73fbe2.tar.xz
testing/py-coreschema: new aport
Diffstat (limited to 'testing/py-coreschema')
-rw-r--r--testing/py-coreschema/APKBUILD59
-rw-r--r--testing/py-coreschema/use-system-py-test.patch5
2 files changed, 64 insertions, 0 deletions
diff --git a/testing/py-coreschema/APKBUILD b/testing/py-coreschema/APKBUILD
new file mode 100644
index 0000000000..50b67a33ee
--- /dev/null
+++ b/testing/py-coreschema/APKBUILD
@@ -0,0 +1,59 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py-coreschema
+_pkgname=${pkgname/py/python}
+pkgver=0.0.4
+pkgrel=0
+pkgdesc="No description or topics provided"
+url="https://github.com/core-api/python-coreschema"
+arch="noarch"
+license="BSD"
+depends="py-jinja2"
+makedepends="python2-dev python3-dev py-setuptools"
+checkdepends="pytest"
+options="!check" #currently broken
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/core-api/python-coreschema/archive/$pkgver.tar.gz
+ use-system-py-test.patch
+ "
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py --quiet build
+ python3 setup.py --quiet build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+}
+
+check() {
+ cd "$builddir"
+ ./runtests
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ local pyver="${1:6:1}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="28badbae07284fb4dbd3f01f613edda1202902115fb166bd95bbac549d398c9e02548b473524d3b530a42319a99d7e55e92bf54269827a9812249cfb285670c3 py-coreschema-0.0.4.tar.gz
+044f95c17094d806e9cacd1bd9d8e358859b24fb0c27f97c47e3dd89f3f16b4151a7b8f47aadfa5e6ca664d185a16e45a947c4a88156a78217f17031191eda14 use-system-py-test.patch"
diff --git a/testing/py-coreschema/use-system-py-test.patch b/testing/py-coreschema/use-system-py-test.patch
new file mode 100644
index 0000000000..cc879d9906
--- /dev/null
+++ b/testing/py-coreschema/use-system-py-test.patch
@@ -0,0 +1,5 @@
+--- a/runtests
++++ b/runtests
+@@ -1,2 +1 @@
+-export PYTHONPATH=.
+ py.test tests/ --cov=coreschema --cov-report html