aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-coveralls
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-12-20 13:20:45 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-12-21 11:28:32 +0000
commitd53f88ccb2df3105ff504cb4e289a26526595ccd (patch)
tree23bbf6a8b4d0a1c8fcdebcce01e8b003dc2e3d50 /testing/py-coveralls
parentbaeae5887cc833191bc0acbe09bbc416820d190c (diff)
downloadaports-d53f88ccb2df3105ff504cb4e289a26526595ccd.tar.bz2
aports-d53f88ccb2df3105ff504cb4e289a26526595ccd.tar.xz
testing/py-coveralls: new aport
Diffstat (limited to 'testing/py-coveralls')
-rw-r--r--testing/py-coveralls/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/py-coveralls/APKBUILD b/testing/py-coveralls/APKBUILD
new file mode 100644
index 0000000000..3a8df889b3
--- /dev/null
+++ b/testing/py-coveralls/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py-coveralls
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="Show coverage stats online via coveralls.io"
+url="https://github.com/coveralls-clients/coveralls-python"
+arch="noarch"
+license="Apache2"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+options="!check" #no testsuite
+source="$pkgname-$pkgver.tar.gz::https://github.com/coveralls-clients/coveralls-python/archive/$pkgver.tar.gz"
+builddir="$srcdir"/coveralls-python-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py --quiet build
+ python3 setup.py --quiet build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ local pyver="${1:6:1}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="56b6f7738558a16e227877735225890164d666e9033ed4629f043cf551dba5799fd916af69667224a5b2328ddb373e404c81a8d5e8265cf24e9e9ab82b9a147d py-coveralls-1.2.0.tar.gz"