aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-discogs-client
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-14 16:46:15 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-14 16:46:15 +0200
commit52b7c6b408f5db358bc271c51dbd05ffb7e8e330 (patch)
treef803d532f6f4ff1132d4852168c15e1a56fd3fd7 /testing/py-discogs-client
parent06bbfed1b8fc636e424bd2be46ce64852fb91a1d (diff)
downloadaports-52b7c6b408f5db358bc271c51dbd05ffb7e8e330.tar.bz2
aports-52b7c6b408f5db358bc271c51dbd05ffb7e8e330.tar.xz
testing/py-discogs-client: new aport
Diffstat (limited to 'testing/py-discogs-client')
-rw-r--r--testing/py-discogs-client/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/py-discogs-client/APKBUILD b/testing/py-discogs-client/APKBUILD
new file mode 100644
index 0000000000..a0537ed87a
--- /dev/null
+++ b/testing/py-discogs-client/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-discogs-client
+pkgver=2.0.2
+pkgrel=0
+pkgdesc="Official Python API client for Discogs"
+url="https://github.com/discogs/discogs_client"
+arch="noarch"
+license="BSD"
+depends="python py-requests py-oauth2"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/d/discogs-client/discogs-client-$pkgver.tar.gz"
+_builddir="$srcdir"/discogs-client-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="2cc57e1d134aa93404e779b9311676fa discogs-client-2.0.2.tar.gz"
+sha256sums="0a3616a818dd9fa61a61c3d9731d176e9123130d1b1b97a6beee63b4c72306b7 discogs-client-2.0.2.tar.gz"
+sha512sums="d562dda57ac3f80f82ae03576d201888a6f0a71362281b62e48def368b9a31b3e3249b784f20da4ca89fa672b6053f9cd27ca66b2fb094321cf803274975b7b2 discogs-client-2.0.2.tar.gz"