aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flake8-author
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-08 22:43:20 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 10:25:27 +0200
commit94a07a6fdd1e1e92ae3d477805cd4f22d3c53d28 (patch)
tree2c9bfb63d0592844c25532394b852b15f1c5d911 /testing/py-flake8-author
parent26ad20823b6bfcc1460fc1b2229abf5f21308d0f (diff)
downloadaports-94a07a6fdd1e1e92ae3d477805cd4f22d3c53d28.tar.bz2
aports-94a07a6fdd1e1e92ae3d477805cd4f22d3c53d28.tar.xz
testing/py-flake8-author: new aport
Flake8 __author__ checker https://github.com/jparise/flake8-author
Diffstat (limited to 'testing/py-flake8-author')
-rw-r--r--testing/py-flake8-author/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py-flake8-author/APKBUILD b/testing/py-flake8-author/APKBUILD
new file mode 100644
index 0000000000..093fdc15bc
--- /dev/null
+++ b/testing/py-flake8-author/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flake8-author
+_pkgname=flake8-author
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="Extension for flake8 to check author's entries"
+url="https://github.com/jparise/flake8-author"
+arch="noarch"
+license="MIT"
+depends="flake8"
+makedepends="python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="64f73e17764bf9f8c43901444f220eb3 flake8-author-1.1.1.tar.gz"
+sha256sums="52a1a9bc9caa15bc9b8675c4b93e3effa67ac1ee4f0cc64f11e7df892fb96912 flake8-author-1.1.1.tar.gz"
+sha512sums="9c789c22b9715639e3608752b17573b64bce6fd8ceac65533571849f151271874950f3297b7ffbc3665c2ab3a3784395fc5abf79b4cd24e817fea0ec1f7448a4 flake8-author-1.1.1.tar.gz"