aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-incoming
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-07 09:10:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:16 +0000
commit0d346ae94a03bb55f0beb80955e64ab58eca4c51 (patch)
tree5814af719a6728b286b2dd9bf89d6c1f61bd2f0a /testing/py-incoming
parentde8f518e4d99fe473239e5ec76699b7b3b77228c (diff)
downloadaports-0d346ae94a03bb55f0beb80955e64ab58eca4c51.tar.bz2
aports-0d346ae94a03bb55f0beb80955e64ab58eca4c51.tar.xz
testing/py-incoming: new aport
A Python JSON validation framework https://github.com/vaidik/incoming
Diffstat (limited to 'testing/py-incoming')
-rw-r--r--testing/py-incoming/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-incoming/APKBUILD b/testing/py-incoming/APKBUILD
new file mode 100644
index 0000000000..2b6035523e
--- /dev/null
+++ b/testing/py-incoming/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-incoming
+_pkgname=incoming
+pkgver=0.2.4
+pkgrel=0
+pkgdesc="A Python JSON validation framework"
+url="https://github.com/vaidik/incoming"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="ffbb309fc1288a0fb4fb79e61036090f incoming-0.2.4.tar.gz"
+sha256sums="acae87e6dfe73f0090e2857a3b95cb0dfcf915fe116d69825bc887187fdf5848 incoming-0.2.4.tar.gz"
+sha512sums="082cb24ecb0f8e684bc68b5912b19d1bfcfd2abddaa796b367d4527cde3d32ced1fb6f615e8fe07bd6956513fe8dacc294ebef8e471f9d2d0284ab1dfcd14f94 incoming-0.2.4.tar.gz"