aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pdfkit
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-07-19 14:35:52 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-07-19 15:06:47 +0200
commit6867bdbe064881b7556a9d1b69fd3cb5f58640a4 (patch)
tree4c47eb13c729ff74c40ad36b375fdbb213bbadbd /testing/py-pdfkit
parent56a6406c37548068ae2d84e5ad7b9dfe9da308da (diff)
downloadaports-6867bdbe064881b7556a9d1b69fd3cb5f58640a4.tar.bz2
aports-6867bdbe064881b7556a9d1b69fd3cb5f58640a4.tar.xz
testing/py-pdfkit: improve abuild
Diffstat (limited to 'testing/py-pdfkit')
-rw-r--r--testing/py-pdfkit/APKBUILD37
1 files changed, 14 insertions, 23 deletions
diff --git a/testing/py-pdfkit/APKBUILD b/testing/py-pdfkit/APKBUILD
index 36f27b174b..6a291d93cf 100644
--- a/testing/py-pdfkit/APKBUILD
+++ b/testing/py-pdfkit/APKBUILD
@@ -1,37 +1,28 @@
# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
# Maintainer:
pkgname=py-pdfkit
+_pkgname=pdfkit
pkgver=0.5.0
-pkgrel=0
+pkgrel=1
pkgdesc="Python wrapper to convert HTML to PDF using the WebKit rendering engine"
-url=https://github.com/JazzCore/python-pdfkit
-arch=noarch
-license=MIT
-depends=wkhtmltopdf
-makedepends=py-setuptools
-source="https://files.pythonhosted.org/packages/source/p/pdfkit/pdfkit-$pkgver.zip"
-
-_builddir=$srcdir/pdfkit-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+url="https://github.com/JazzCore/python-pdfkit"
+arch="noarch"
+license="MIT"
+depends="wkhtmltopdf"
+makedepends="py-setuptools"
+source="$pkgname-$pkgver.zip::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
python setup.py build
}
package() {
- cd "$_builddir"
+ cd "$builddir"
python setup.py install --root "$pkgdir"
}
-md5sums="5cbe42c43d463f0794272a01e37a553f pdfkit-0.5.0.zip"
-sha256sums="6e176cf460d8f8996d4c316aef1189e1c1c134d28d47a1e5e783e250ee3335dc pdfkit-0.5.0.zip"
-sha512sums="7d310d36503305bf71065b9b96bb313cb21f40ad7c347554b6f7a82e3d7ee8a7e3122ce54a522fbbacb5c50f0ddb72c9827bc0b38aa1ebea891e5c91b2668841 pdfkit-0.5.0.zip"
+md5sums="5cbe42c43d463f0794272a01e37a553f py-pdfkit-0.5.0.zip"
+sha256sums="6e176cf460d8f8996d4c316aef1189e1c1c134d28d47a1e5e783e250ee3335dc py-pdfkit-0.5.0.zip"
+sha512sums="7d310d36503305bf71065b9b96bb313cb21f40ad7c347554b6f7a82e3d7ee8a7e3122ce54a522fbbacb5c50f0ddb72c9827bc0b38aa1ebea891e5c91b2668841 py-pdfkit-0.5.0.zip"