aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pep8-naming
diff options
context:
space:
mode:
authordai9ah <dai9ah@protonmail.com>2018-02-26 13:41:59 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-05 23:28:10 +0000
commit1cded1fcdd8bed01c5e6ae0c8d7ecc2e1a7da3a6 (patch)
tree03b3cf7ca74726446981af8846726cdf257fd9a5 /testing/py-pep8-naming
parent6d42e1458cf7f007ab4e31148eb471f944105894 (diff)
downloadaports-1cded1fcdd8bed01c5e6ae0c8d7ecc2e1a7da3a6.tar.bz2
aports-1cded1fcdd8bed01c5e6ae0c8d7ecc2e1a7da3a6.tar.xz
testing/py-pep8-naming: add python3, add check
Diffstat (limited to 'testing/py-pep8-naming')
-rw-r--r--testing/py-pep8-naming/APKBUILD35
1 files changed, 31 insertions, 4 deletions
diff --git a/testing/py-pep8-naming/APKBUILD b/testing/py-pep8-naming/APKBUILD
index 9128bc5eda..c3d7a22f11 100644
--- a/testing/py-pep8-naming/APKBUILD
+++ b/testing/py-pep8-naming/APKBUILD
@@ -8,22 +8,49 @@ pkgdesc="Check PEP-8 naming conventions plugin for flake8"
url="https://github.com/flintwork/pep8-naming"
arch="noarch"
license="MIT"
-depends="python2 flake8"
+depends="python2 python3 py-flake8"
depends_dev=""
-makedepends="python2-dev py-setuptools"
+makedepends="python2-dev python3-dev py-setuptools"
+checkdepends="py-tox py-virtualenv"
install=""
-subpackages=""
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
_builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$_builddir"
python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$_builddir"
+ tox
}
package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
}
sha512sums="edf3c85140dda2ccfc172b75b8d65d70623446892e944d1b282fc64196d30ef96e21f02b519b6846e8e738acb28902ac60fdf61e276da59f5d722bba7554694f pep8-naming-0.5.0.tar.gz"