aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pykka
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-16 13:40:36 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-16 13:40:49 +0200
commit57502b4a24311ad43fe38081554ec255f08fcd69 (patch)
tree074c737c36839c4b10ed825a482a08121a08e87d /testing/py-pykka
parent1f2be1045f178be10be646ad8a88e3fe6adf146f (diff)
downloadaports-57502b4a24311ad43fe38081554ec255f08fcd69.tar.bz2
aports-57502b4a24311ad43fe38081554ec255f08fcd69.tar.xz
testing/py-pykka: new aport
Diffstat (limited to 'testing/py-pykka')
-rw-r--r--testing/py-pykka/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/py-pykka/APKBUILD b/testing/py-pykka/APKBUILD
new file mode 100644
index 0000000000..561cd5e6fa
--- /dev/null
+++ b/testing/py-pykka/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-pykka
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="Easy to use concurrency abstractions for Python using the actor model"
+url="http://pykka.readthedocs.org/"
+arch="noarch"
+license="Apache"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/P/Pykka/Pykka-$pkgver.tar.gz"
+
+_builddir="$srcdir"/Pykka-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="27cb69507f89e34dc1ff34636c4bc165 Pykka-1.2.0.tar.gz"
+sha256sums="01cfbfc5a9a32c01ee68303614269b5b1c6e3d698270c92be7488f8c1edb5885 Pykka-1.2.0.tar.gz"
+sha512sums="9fd6537d3ee8a6ef1882737bdcb8542aa411a857adbe1c4464a825baf1d30f9b000f523abd947b89bcf9e08437eaa589b10aaeb16cc78aa5f41ca40e531ecb34 Pykka-1.2.0.tar.gz"