aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pykka
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-12 19:15:07 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-05-08 09:26:56 +0000
commitb41e4058183210bd59ea5046f932cf5a50265934 (patch)
treef1e328a4cebbbbc7d2cca9843c5adb5510a402e9 /testing/py-pykka
parent0ebbfe9e14b7a596c041a4c8b0b243aeea4f8122 (diff)
downloadaports-b41e4058183210bd59ea5046f932cf5a50265934.tar.bz2
aports-b41e4058183210bd59ea5046f932cf5a50265934.tar.xz
testing/py-pykka: add python3
Diffstat (limited to 'testing/py-pykka')
-rw-r--r--testing/py-pykka/APKBUILD30
1 files changed, 25 insertions, 5 deletions
diff --git a/testing/py-pykka/APKBUILD b/testing/py-pykka/APKBUILD
index da7aad0cb4..52aa1b692d 100644
--- a/testing/py-pykka/APKBUILD
+++ b/testing/py-pykka/APKBUILD
@@ -2,27 +2,47 @@
# Maintainer:
pkgname=py-pykka
pkgver=1.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="Easy to use concurrency abstractions for Python using the actor model"
url="http://pykka.readthedocs.org/"
arch="noarch"
license="Apache"
-depends="python2"
+depends="python2 python3"
depends_dev=""
-makedepends="python2-dev py2-setuptools"
+makedepends="python2-dev python3-dev py-setuptools"
install=""
-subpackages=""
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/P/Pykka/Pykka-$pkgver.tar.gz"
+
_builddir="$srcdir"/Pykka-$pkgver
build() {
cd "$_builddir"
python2 setup.py build
+ python3 setup.py build
}
package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
}
sha512sums="22eaa735915e33146d8a3fa3f9dd5ea1dd608e7ad45ab21721a108b01ddf058b4cd00da67b762a95ede650c9ba1a79ee3d6fd22a491bc7ff348a56b7c0139cfd Pykka-1.2.1.tar.gz"