aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pykka
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2018-05-08 09:33:20 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-05-08 09:33:20 +0000
commitbd657a0be4d0b736b5a84a5f6b0230f709c30ae5 (patch)
treecf6f6e0ceeac0e17bce51661d744e4c0247b3f1e /testing/py-pykka
parent77ed4d989d78f98af4b8629c34f606cedcfe4017 (diff)
downloadaports-bd657a0be4d0b736b5a84a5f6b0230f709c30ae5.tar.bz2
aports-bd657a0be4d0b736b5a84a5f6b0230f709c30ae5.tar.xz
testing/py-pykka: added check()
Diffstat (limited to 'testing/py-pykka')
-rw-r--r--testing/py-pykka/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/testing/py-pykka/APKBUILD b/testing/py-pykka/APKBUILD
index 4fca8eb361..ff4317acbe 100644
--- a/testing/py-pykka/APKBUILD
+++ b/testing/py-pykka/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=py-pykka
pkgver=1.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Concurrency abstractions for Python using the actor model"
url="http://pykka.readthedocs.org"
arch="noarch"
@@ -26,6 +26,13 @@ package() {
mkdir -p "$pkgdir"
}
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+
_py2() {
replaces="$pkgname"
_py python2