aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-sphinx-theme-wild
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-17 18:39:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-02 09:02:53 +0000
commit02084e4a286313d5044fd239084a72f68d015874 (patch)
treeeb194cc99c8f03d78fc35a35e6fc92955f626c7e /testing/py-sphinx-theme-wild
parent8a39c228690a1269730a6310a771270c07c95a11 (diff)
downloadaports-02084e4a286313d5044fd239084a72f68d015874.tar.bz2
aports-02084e4a286313d5044fd239084a72f68d015874.tar.xz
testing/py-sphinx-theme-wild: new aport
The Wild Sphinx theme https://github.com/rhardouin/wild-sphinx-theme
Diffstat (limited to 'testing/py-sphinx-theme-wild')
-rw-r--r--testing/py-sphinx-theme-wild/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-sphinx-theme-wild/APKBUILD b/testing/py-sphinx-theme-wild/APKBUILD
new file mode 100644
index 0000000000..f1670c219e
--- /dev/null
+++ b/testing/py-sphinx-theme-wild/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinx-theme-wild
+_pkgname=wild_sphinx_theme
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="The Wild Sphinx theme"
+url="https://github.com/rhardouin/wild-sphinx-theme"
+arch="noarch"
+license="BSD"
+depends="python py-sphinx"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="8789617bd4e5cc43bea3b8a166abadb6 wild_sphinx_theme-1.0.0.tar.gz"
+sha256sums="45f7f704ccb735baa7d23ad317315f0fbbd5f7df5044a294c0c2255f1b380f5b wild_sphinx_theme-1.0.0.tar.gz"
+sha512sums="1bada8f8cd22fdd725cf5898d3598d29a6745315c005d9be25dba0b27e2af1cc7e798aaee3200d1f70346cb50360e11358bd690cd9339eb64d8f383fb78bbe0a wild_sphinx_theme-1.0.0.tar.gz"