aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-sphinxcontrib-seqdiag
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-07 22:17:27 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 09:50:46 +0200
commitc8f5becbaa284e5f2eed94d31848ec8d0a856ee4 (patch)
tree79664bcd6ddb28d63db72042188b535807128333 /testing/py-sphinxcontrib-seqdiag
parenta6c826c8917f8d90195d349c1c415f7de0ad1bc5 (diff)
downloadaports-c8f5becbaa284e5f2eed94d31848ec8d0a856ee4.tar.bz2
aports-c8f5becbaa284e5f2eed94d31848ec8d0a856ee4.tar.xz
testing/py-sphinxcontrib-seqdiag: upgrade to 0.8.5 and enable py3
Diffstat (limited to 'testing/py-sphinxcontrib-seqdiag')
-rw-r--r--testing/py-sphinxcontrib-seqdiag/APKBUILD48
1 files changed, 34 insertions, 14 deletions
diff --git a/testing/py-sphinxcontrib-seqdiag/APKBUILD b/testing/py-sphinxcontrib-seqdiag/APKBUILD
index 190651fd29..2145363982 100644
--- a/testing/py-sphinxcontrib-seqdiag/APKBUILD
+++ b/testing/py-sphinxcontrib-seqdiag/APKBUILD
@@ -2,23 +2,21 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-sphinxcontrib-seqdiag
_pkgname=sphinxcontrib-seqdiag
-pkgver=0.8.1
+pkgver=0.8.5
pkgrel=0
pkgdesc="Sphinx "seqdiag" extension"
url="https://pypi.python.org/pypi/sphinxcontrib-seqdiag"
arch="noarch"
license="BSD"
-depends="python2 py-sphinx py-seqdiag"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+depends="py-sphinx py-seqdiag"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
-_builddir="$srcdir"/$_pkgname-$pkgver
prepare() {
local i
- cd "$_builddir"
+ cd "$builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -27,15 +25,37 @@ prepare() {
}
build() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ mkdir -p "$pkgdir"
}
-md5sums="ef9ad01798b5cf46247ab1fbe4ff781c sphinxcontrib-seqdiag-0.8.1.tar.gz"
-sha256sums="e7b19fbeb5cc39f27a7453d4e9b502e936e8808893b070d77dabf77a945bfd95 sphinxcontrib-seqdiag-0.8.1.tar.gz"
-sha512sums="b9a967181339ec8d16d9f14304248631aaeabc9e1dc8687be15d076b7835edb2d7f7eaed98e0832d9521ff177d5f4d35065aa9e8118732ee1648e833d07532fd sphinxcontrib-seqdiag-0.8.1.tar.gz"
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+
+md5sums="01a002b2898bf5e0626e03f653863ce3 sphinxcontrib-seqdiag-0.8.5.tar.gz"
+sha256sums="83c3fdac7e083c5b217f65359c03b75af753209028db6b261b196aff19e7003f sphinxcontrib-seqdiag-0.8.5.tar.gz"
+sha512sums="dcdce24bbf29a060e2344fbab423253e7810547ec6352fa949d392f98c33f008cac25d12e81029441b4303339133d3c6d4010b8aac27ad318b6e8b3b75b35f52 sphinxcontrib-seqdiag-0.8.5.tar.gz"