aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-usb
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2018-07-17 16:06:17 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-07-18 07:04:25 +0000
commit1ad36959e0d5c54935b183c11cc09d5adacf6f65 (patch)
tree6c64043e4fd0b63e64c1784d06798a82cb56ca6b /testing/py-usb
parent1e9ed2c300ef7ded8ec8dd15cd198414cf778616 (diff)
downloadaports-1ad36959e0d5c54935b183c11cc09d5adacf6f65.tar.bz2
aports-1ad36959e0d5c54935b183c11cc09d5adacf6f65.tar.xz
testing/py-usb: New aport
PyUSB offers easy USB devices communication in Python https://pypi.python.org/pypi/pyusb
Diffstat (limited to 'testing/py-usb')
-rw-r--r--testing/py-usb/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/py-usb/APKBUILD b/testing/py-usb/APKBUILD
new file mode 100644
index 0000000000..a43e731aef
--- /dev/null
+++ b/testing/py-usb/APKBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py-usb
+_pkgname=pyusb
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="PyUSB offers easy USB devices communication in Python"
+url="https://pypi.python.org/pypi/pyusb"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+sha512sums="218d118c8572ed548d2317725a9717c0a442eb67c05148ccd90505a407bd8821a1519f511abc14f96b8e09d914f5a35f57cfabd57c47cb9b3fcd8b61947375a2 pyusb-1.0.2.tar.gz"