aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-websocket-client/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-04-06 07:35:02 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-04-06 07:35:02 +0000
commit6c90adf0110499fabb628cba715ac6b40cbd40ae (patch)
treefbcf4184003d339589cd1f674bde23eed74d22b6 /testing/py-websocket-client/APKBUILD
parentf664028ee0291bd358d2a3e9d652d2424f36fafa (diff)
downloadaports-6c90adf0110499fabb628cba715ac6b40cbd40ae.tar.bz2
aports-6c90adf0110499fabb628cba715ac6b40cbd40ae.tar.xz
testing/py-websocket-client: new aport
Diffstat (limited to 'testing/py-websocket-client/APKBUILD')
-rw-r--r--testing/py-websocket-client/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py-websocket-client/APKBUILD b/testing/py-websocket-client/APKBUILD
new file mode 100644
index 0000000000..601e927328
--- /dev/null
+++ b/testing/py-websocket-client/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-websocket-client
+_pkgname=websocket_client
+pkgver=0.35.0
+pkgrel=0
+pkgdesc="WebSocket client library for Python"
+url="https://github.com/liris/websocket-client"
+arch="noarch"
+license="LGPL"
+depends="python"
+depends_dev=""
+makedepends="$depends_dev py-setuptools py-six"
+install=""
+subpackages="$pkgname-doc"
+source="http://pypi.python.org/packages/source/w/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+md5sums="37015cccff457f841c6f21bae86fa2d0 websocket_client-0.35.0.tar.gz"
+sha256sums="5ac3ead091be17b680a0dda926aef1a697a2b6cf1e9ac0fbe4bffb14914c2116 websocket_client-0.35.0.tar.gz"
+sha512sums="d2bfb27f1908882621db21badc9f665ed7b0c0164f47c29014fc87ae7aa52b81160c11b26dd8abd97ced5a3429a917034b1a94dfd8ecfa91637dec9d2857475a websocket_client-0.35.0.tar.gz"