aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pysocks/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-24 14:19:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-24 15:23:25 +0000
commitab37ff94c6b0f8418d2b823dbe514fe49a3992cf (patch)
treee6fa8b173b5c050b6172db279442c2c07ae14675 /testing/py3-pysocks/APKBUILD
parent76de376c496f8534f8741e025a1f76d936a6e11f (diff)
downloadaports-ab37ff94c6b0f8418d2b823dbe514fe49a3992cf.tar.bz2
aports-ab37ff94c6b0f8418d2b823dbe514fe49a3992cf.tar.xz
testing/py3-pysocks: new aport
Python Socks module https://github.com/Anorov/PySocks
Diffstat (limited to 'testing/py3-pysocks/APKBUILD')
-rw-r--r--testing/py3-pysocks/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-pysocks/APKBUILD b/testing/py3-pysocks/APKBUILD
new file mode 100644
index 0000000000..a835b9f768
--- /dev/null
+++ b/testing/py3-pysocks/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=py3-pysocks
+pkgver=1.6.8
+pkgrel=0
+pkgdesc="Python Socks module"
+url="https://github.com/Anorov/PySocks"
+arch="noarch"
+license="BSD"
+depends="python3"
+makedepends="python3-dev"
+source="https://pypi.io/packages/source/P/PySocks/PySocks-$pkgver.tar.gz"
+builddir="$srcdir/PySocks-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="9b544cf11464142a5f347cd5688b48422249363a425ccf3887117152f2f1969713674c4bba714242432ae85f3d62e03edeb9cb7b73ebd225ed3b47b3da6896d5 PySocks-1.6.8.tar.gz"