aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-texttable
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-24 14:23:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-24 15:23:25 +0000
commit60ffb9bf70fb61cdd060a2d3d3ca7b7d9bcfd152 (patch)
treec6357cd301e99d9893b85fecad92549fd37fc579 /testing/py3-texttable
parentab37ff94c6b0f8418d2b823dbe514fe49a3992cf (diff)
downloadaports-60ffb9bf70fb61cdd060a2d3d3ca7b7d9bcfd152.tar.bz2
aports-60ffb9bf70fb61cdd060a2d3d3ca7b7d9bcfd152.tar.xz
testing/py3-texttable: new aport
module for creating simple ASCII tables https://github.com/foutaise/texttable/
Diffstat (limited to 'testing/py3-texttable')
-rw-r--r--testing/py3-texttable/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-texttable/APKBUILD b/testing/py3-texttable/APKBUILD
new file mode 100644
index 0000000000..c58340e34c
--- /dev/null
+++ b/testing/py3-texttable/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py3-texttable
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="module for creating simple ASCII tables"
+url="https://github.com/foutaise/texttable/"
+arch="all"
+license="LGPL-3.0"
+depends="python3"
+makedepends="python3-dev"
+source="https://pypi.io/packages/source/t/texttable/texttable-$pkgver.tar.gz"
+builddir="$srcdir/texttable-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="41d1b429ee32cd717d273152da0263cfff13d79aae7ecc69bda455c1391ea1e6cf74b412e6043bf3d32d62932b4498a2484deb997ef545fdd6195fd5ebd58fc5 texttable-1.4.0.tar.gz"