aboutsummaryrefslogtreecommitdiffstats
path: root/testing/shairport-sync
diff options
context:
space:
mode:
authorLinux User <rattle@raspberry.my.domain>2017-08-16 14:32:53 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-22 23:40:35 +0200
commit6fd27867cf27c04df09660da3c83299515a29313 (patch)
tree27f4a08bf11666f3de2ac7d9e1da564d77dc3c90 /testing/shairport-sync
parent4ad2b82edf1723c0e898ca9d85cefe4d7001143c (diff)
downloadaports-6fd27867cf27c04df09660da3c83299515a29313.tar.bz2
aports-6fd27867cf27c04df09660da3c83299515a29313.tar.xz
testing/shairport-sync: upgrade to 3.1.1
Removed pid file check patch since it's not needed anymore
Diffstat (limited to 'testing/shairport-sync')
-rw-r--r--testing/shairport-sync/APKBUILD13
-rw-r--r--testing/shairport-sync/dont-check-pidfile-when-not-daemonised.patch42
2 files changed, 6 insertions, 49 deletions
diff --git a/testing/shairport-sync/APKBUILD b/testing/shairport-sync/APKBUILD
index 1906860178..8dae24f5fc 100644
--- a/testing/shairport-sync/APKBUILD
+++ b/testing/shairport-sync/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=shairport-sync
-pkgver=3.0.2
-pkgrel=2
+pkgver=3.1.1
+pkgrel=0
pkgdesc="AirTunes emulator. Shairport Sync adds multi-room capability with Audio Synchronisation"
url="https://github.com/mikebrady/shairport-sync"
arch="all"
@@ -12,12 +12,12 @@ makedepends="autoconf automake libtool alsa-lib-dev libdaemon-dev popt-dev
libressl-dev soxr-dev avahi-dev libconfig-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/mikebrady/$pkgname/archive/$pkgver.tar.gz
- $pkgname.initd
- dont-check-pidfile-when-not-daemonised.patch"
+ $pkgname.initd"
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare
+ cd "$builddir"
autoreconf -i -f
}
@@ -47,6 +47,5 @@ package() {
install -m 755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
}
-sha512sums="071593cd264848209031469469d182a428ec132cb646a402eb30ae51e5d2eb78c436d6c4567d2e0583cf10788a5a5221e35cf81c95fab628d7da9bc0f3ff0328 shairport-sync-3.0.2.tar.gz
-aeead51ef0f17d360bb1e2d2ae897974ef507ef56db84e6aeb79d8ec522c3bb9336f01ff4150e70fecfebf9808dd7190cb2839e287cf0ef6e1886504c1f1edc6 shairport-sync.initd
-32a63cd86e8eb81e66c0ed39053f57ff3dfdfc3396c4a683368fb3222ad08e1c330f33b548f094e6f64ffb5129bfa1d4ce1794190651f9e6f77228a2f3336cd6 dont-check-pidfile-when-not-daemonised.patch"
+sha512sums="46a44acabdf2cfeef1187ad7a37173ba2153c7c5d8729d62f5eaf67dade5d134ed12764f200763d199d2e89e19d88566eacb04dfd0b27e8970277bad37780f2d shairport-sync-3.1.1.tar.gz
+aeead51ef0f17d360bb1e2d2ae897974ef507ef56db84e6aeb79d8ec522c3bb9336f01ff4150e70fecfebf9808dd7190cb2839e287cf0ef6e1886504c1f1edc6 shairport-sync.initd"
diff --git a/testing/shairport-sync/dont-check-pidfile-when-not-daemonised.patch b/testing/shairport-sync/dont-check-pidfile-when-not-daemonised.patch
deleted file mode 100644
index aabeb818c8..0000000000
--- a/testing/shairport-sync/dont-check-pidfile-when-not-daemonised.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From: Jakub Jirutka <jakub@jirutka.cz>
-Date: Tue, 11 Apr 2017 12:24:00 +0200
-Subject: [PATCH] Don't check pidfile when not --daemon
-
-shairport reads pidfile to check if it's not already running even when
-started without -d / --daemon. Thus it cannot be properly started by
-init system without enabling --daemon (that's a bad practice).
-
-This patch fixes this behaviour.
-
---- a/shairport.c
-+++ b/shairport.c
-@@ -87,7 +87,9 @@
- shairport_shutdown();
- // daemon_log(LOG_NOTICE, "exit...");
- daemon_retval_send(255);
-- daemon_pid_file_remove();
-+ if (config.daemonise) {
-+ daemon_pid_file_remove();
-+ }
- exit(0);
- }
-
-@@ -997,7 +999,7 @@
- }
-
- /* Check that the daemon is not running twice at the same time */
-- if ((pid = daemon_pid_file_is_running()) >= 0) {
-+ if (config.daemonise && (pid = daemon_pid_file_is_running()) >= 0) {
- daemon_log(LOG_ERR, "Daemon already running on PID file %u", pid);
- return 1;
- }
-@@ -1257,6 +1259,8 @@
- finish:
- daemon_log(LOG_NOTICE, "Unexpected exit...");
- daemon_retval_send(255);
-- daemon_pid_file_remove();
-+ if (config.daemonise) {
-+ daemon_pid_file_remove();
-+ }
- return 1;
- }