aboutsummaryrefslogtreecommitdiffstats
path: root/testing/shairport-sync
diff options
context:
space:
mode:
authorHenrik Nilsson <henrik.nilsson@bytequest.se>2017-04-05 17:49:40 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-11 13:52:14 +0200
commitc280e19e3045d953eab484084224b6500644ceb1 (patch)
tree2e8a2ee172292fcd9f0beb4114cd28f7bb6e3323 /testing/shairport-sync
parent5c20bfd8ebbb9ded7ff99c53c376799fc549a193 (diff)
downloadaports-c280e19e3045d953eab484084224b6500644ceb1.tar.bz2
aports-c280e19e3045d953eab484084224b6500644ceb1.tar.xz
testing/shairport-sync: add init script
Diffstat (limited to 'testing/shairport-sync')
-rw-r--r--testing/shairport-sync/APKBUILD10
-rw-r--r--testing/shairport-sync/shairport-sync.initd10
2 files changed, 15 insertions, 5 deletions
diff --git a/testing/shairport-sync/APKBUILD b/testing/shairport-sync/APKBUILD
index 78bb275e5f..dfc491879e 100644
--- a/testing/shairport-sync/APKBUILD
+++ b/testing/shairport-sync/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=shairport-sync
pkgver=3.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="AirTunes emulator. Shairport Sync adds multi-room capability with Audio Synchronisation"
url="https://github.com/mikebrady/shairport-sync"
arch="all"
@@ -14,7 +14,7 @@ makedepends="$depends_dev autoconf automake libtool"
install=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/mikebrady/shairport-sync/archive/$pkgver.tar.gz
- "
+ $pkgname.initd"
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
@@ -49,8 +49,8 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
+ install -m 755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
}
-md5sums="e212a4028cfbae74c1931b989825e76f shairport-sync-3.0.2.tar.gz"
-sha256sums="b348b9b3cf3994d9222430bc514c94a22f2ed173956fdb097f3354cdba8fd198 shairport-sync-3.0.2.tar.gz"
-sha512sums="071593cd264848209031469469d182a428ec132cb646a402eb30ae51e5d2eb78c436d6c4567d2e0583cf10788a5a5221e35cf81c95fab628d7da9bc0f3ff0328 shairport-sync-3.0.2.tar.gz"
+sha512sums="071593cd264848209031469469d182a428ec132cb646a402eb30ae51e5d2eb78c436d6c4567d2e0583cf10788a5a5221e35cf81c95fab628d7da9bc0f3ff0328 shairport-sync-3.0.2.tar.gz
+4fc22ddaa566c23b02d5cbd5cecf5374ea264e864d735170e6194e4b2c940f57515875a28e5c0886982ab32c75fa0eee0d33a0ed60438420da2478bc0d441b21 shairport-sync.initd"
diff --git a/testing/shairport-sync/shairport-sync.initd b/testing/shairport-sync/shairport-sync.initd
new file mode 100644
index 0000000000..31f7643c83
--- /dev/null
+++ b/testing/shairport-sync/shairport-sync.initd
@@ -0,0 +1,10 @@
+#!/sbin/openrc-run
+
+description="Implements a synchronous (multi-room-capable) AirPlay receiver"
+command="/usr/bin/shairport-sync"
+command_args="-d"
+pidfile="/run/$RC_SVCNAME.pid"
+
+depend() {
+ need net localmount avahi-daemon
+}