aboutsummaryrefslogtreecommitdiffstats
path: root/testing/spice-vdagent/APKBUILD
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2015-04-20 11:14:34 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2015-04-27 07:15:14 +0000
commit0eecc344f01e57415f31798cf8c27f7f0796ad9b (patch)
treef9bdb3bd431c6feddeea4d30ccd16162663218ef /testing/spice-vdagent/APKBUILD
parent3bbd14339e193fb2e619868b96463ad2eb6cc6dd (diff)
downloadaports-0eecc344f01e57415f31798cf8c27f7f0796ad9b.tar.bz2
aports-0eecc344f01e57415f31798cf8c27f7f0796ad9b.tar.xz
testing/spice-vdagent: fix copy / paste functionality
This patch adds an init script for copy & paste functionality between the guest & host. Run 'rc-service spice-vdagentd info' for details on the settings for libvirt. By default this runs with a single session possible. For multiple sessions remove '-X' to disable consolekit from the init script & install slim or lxdm. Tested on 32 & 64 bit KVM - but should also work on XEN / LXC run by libvirt. Signed-off-by: Leonardo Arena <rnalrd@alpinelinux.org>
Diffstat (limited to 'testing/spice-vdagent/APKBUILD')
-rw-r--r--testing/spice-vdagent/APKBUILD23
1 files changed, 17 insertions, 6 deletions
diff --git a/testing/spice-vdagent/APKBUILD b/testing/spice-vdagent/APKBUILD
index feb52cffae..656e251481 100644
--- a/testing/spice-vdagent/APKBUILD
+++ b/testing/spice-vdagent/APKBUILD
@@ -8,11 +8,14 @@ arch="all"
license="GPLv3+"
depends=""
depends_dev=""
-makedepends="$depends_dev glib-dev spice-protocol libpciaccess-dev
- libxrandr-dev libxinerama-dev libxfixes-dev"
+makedepends="$depends_dev glib-dev spice-protocol libpciaccess-dev dbus-dev
+ libxrandr-dev libxinerama-dev libxfixes-dev linux-headers"
install=""
subpackages="$pkgname-doc"
-source="http://spice-space.org/download/releases/spice-vdagent-$pkgver.tar.bz2"
+source="http://spice-space.org/download/releases/spice-vdagent-$pkgver.tar.bz2
+ "$pkgname"d.initd
+ fix-memcpy-memset-implicit-declaration.patch
+ "
_builddir="$srcdir"/spice-vdagent-$pkgver
prepare() {
@@ -43,8 +46,16 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm -f "$pkgdir"/usr/lib/*.la
+ install -m755 -D "$srcdir/$pkgname"d.initd \
+ "$pkgdir"/etc/init.d/"$pkgname"d || return 1
}
-md5sums="2919ac7a4195b0b4b2588fae90a9241c spice-vdagent-0.15.0.tar.bz2"
-sha256sums="5bae1747307c2f4195f6de97639391be7c6be6c5673fdcc9febed6faca22bd34 spice-vdagent-0.15.0.tar.bz2"
-sha512sums="7d3bdeca2a8a5a63f817c8b0c1c46508e3238e0d2f3a018e44ffa4c7a2b7d0e82b0a2c37a6f35c59fcb23d89de82312edb689dc1de6fdf659004e640b900f436 spice-vdagent-0.15.0.tar.bz2"
+md5sums="2919ac7a4195b0b4b2588fae90a9241c spice-vdagent-0.15.0.tar.bz2
+c707c8127d647a9f5e2c99cd213dc0b3 spice-vdagentd.initd
+083cdf808a24d1855d09a93a52dbeccd fix-memcpy-memset-implicit-declaration.patch"
+sha256sums="5bae1747307c2f4195f6de97639391be7c6be6c5673fdcc9febed6faca22bd34 spice-vdagent-0.15.0.tar.bz2
+b61b09be015148dbaeb2047b1da9e96163920e34176cd6507d7d3cb9f872e083 spice-vdagentd.initd
+69bbdffc46bd247f5fdee84e8a06d86b0a59e8dc53e9dc5eb0fd8055d87b9323 fix-memcpy-memset-implicit-declaration.patch"
+sha512sums="7d3bdeca2a8a5a63f817c8b0c1c46508e3238e0d2f3a018e44ffa4c7a2b7d0e82b0a2c37a6f35c59fcb23d89de82312edb689dc1de6fdf659004e640b900f436 spice-vdagent-0.15.0.tar.bz2
+322a72ebfa978366e04b2aec49258fda2f2535fa21470a5c0a7e41a295b61dc57f657270836be99733e0111dc2b2da6c005d05f93dcf592bb280284b080b25c1 spice-vdagentd.initd
+381f974580aa478a9c0a35d7e6cc5bee57903f47929dea143ee2ddda9952d4b3ed6180a2b2e90ef83b01425d46507ea18bba01c42d32739fd0cc85bcbac59537 fix-memcpy-memset-implicit-declaration.patch"