aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tc-play/libsuffix.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-07-07 12:29:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-07-07 13:42:09 +0000
commit3cf1beea8339ec4437ecc19b66e003724691311f (patch)
treec5565e67666cc57347c5c72ce931beb37fcec78e /testing/tc-play/libsuffix.patch
parentbd1b9e824097668d7ea9fdfa246af1a6f6db0dcf (diff)
downloadaports-3cf1beea8339ec4437ecc19b66e003724691311f.tar.bz2
aports-3cf1beea8339ec4437ecc19b66e003724691311f.tar.xz
testing/tc-play: new aport
Free and simple TrueCrypt Implementation based on dm-crypt https://github.com/bwalex/tc-play
Diffstat (limited to 'testing/tc-play/libsuffix.patch')
-rw-r--r--testing/tc-play/libsuffix.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/tc-play/libsuffix.patch b/testing/tc-play/libsuffix.patch
new file mode 100644
index 0000000000..31f1e22d36
--- /dev/null
+++ b/testing/tc-play/libsuffix.patch
@@ -0,0 +1,24 @@
+--- ./CMakeLists.txt.orig
++++ ./CMakeLists.txt
+@@ -63,21 +63,6 @@
+ endif()
+
+
+-if (NOT LIB_SUFFIX)
+- message(STATUS "")
+- message(STATUS "LIB_SUFFIX variable is not defined. It will be autodetected now.")
+- message(STATUS "You can set it manually with -DLIB_SUFFIX=<value> (e.g. 64).")
+- if (CMAKE_SIZEOF_VOID_P EQUAL 8)
+- message(STATUS "\nSetting LIB_SUFFIX=64\n")
+- set (LIB_SUFFIX "64")
+- else()
+- message(STATUS "\nSetting LIB_SUFFIX=\n")
+- set (LIB_SUFFIX "")
+- endif()
+-endif()
+-
+-
+-
+ add_executable(tcplay-bin main.c ${SRCS_COMMON} ${SRCS_LINUX} ${SRCS_PBKDF})
+ set_target_properties(tcplay-bin PROPERTIES OUTPUT_NAME tcplay)
+ set_target_properties(tcplay-bin PROPERTIES COMPILE_FLAGS "${CFLAGS_COMMON} ${DEVMAPPER_CFLAGS} ${UUID_CFLAGS} ${GCRYPT_CFLAGS}")