aboutsummaryrefslogtreecommitdiffstats
path: root/testing/texlive
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-08-25 19:46:06 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-08-26 15:31:48 +0200
commit6b5d67c68dbf7eb21bbbc3266c164ed0d6b20227 (patch)
tree950f9363c5cf0bb13c8ed7939fcf7a01e4da8281 /testing/texlive
parentc8e3091eac2b59d5e3ae889094ab8cd23c135527 (diff)
downloadaports-6b5d67c68dbf7eb21bbbc3266c164ed0d6b20227.tar.bz2
aports-6b5d67c68dbf7eb21bbbc3266c164ed0d6b20227.tar.xz
testing/texlive: sort configure flags and add banner
No pkgrel bump since this doesn't change the binary in a significant way.
Diffstat (limited to 'testing/texlive')
-rw-r--r--testing/texlive/APKBUILD65
1 files changed, 33 insertions, 32 deletions
diff --git a/testing/texlive/APKBUILD b/testing/texlive/APKBUILD
index bcb997fc4d..322ac82029 100644
--- a/testing/texlive/APKBUILD
+++ b/testing/texlive/APKBUILD
@@ -38,54 +38,55 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
- --with-system-freetype2 \
- --with-system-zlib \
- --with-system-libpng \
- --with-system-xpdf \
- --with-system-poppler \
- --with-system-icu \
- --with-system-harfbuzz \
- --with-system-icu \
- --with-system-graphite2 \
- --with-system-cairo \
- --with-system-pixman \
- --with-system-zziplib \
- --with-system-libpaper \
- --without-texinfo \
- --disable-dialog \
- --disable-multiplatform \
--enable-epsfwin \
+ --enable-ipc \
+ --enable-luatex \
--enable-mftalkwin \
--enable-regiswin \
+ --enable-shared \
--enable-tektronixwin \
--enable-unitermwin \
- --with-ps=gs \
- --disable-psutils \
- --disable-t1utils \
- --enable-ipc \
+ --enable-xetex \
--disable-biber \
--disable-bibtex-x \
+ --disable-chktex \
+ --disable-cjkutils \
+ --disable-detex \
+ --disable-dialog \
+ --disable-dvi2tty \
--disable-dvipng \
--disable-dvipsk \
- --disable-chktex \
+ --disable-dvisvgm \
+ --disable-largefile \
--disable-lcdf-typetools \
+ --disable-multiplatform \
+ --disable-native-texlive-build \
--disable-pdfopen \
--disable-ps2eps \
--disable-ps2pkm \
- --disable-detex \
- --disable-ttf2pk2 \
+ --disable-psutils \
+ --disable-t1utils \
--disable-tex4htk \
- --disable-cjkutils \
+ --disable-ttf2pk2 \
+ --disable-vlna \
--disable-xdvik \
--disable-xindy \
- --enable-luatex \
- --disable-dvi2tty \
- --disable-dvisvgm \
- --disable-vlna \
- --enable-shared \
- --disable-native-texlive-build \
- --disable-largefile \
- --enable-xetex \
+ --with-ps=gs \
+ --with-banner-add="/Alpine Linux" \
+ --with-system-cairo \
+ --with-system-freetype2 \
+ --with-system-graphite2 \
+ --with-system-harfbuzz \
+ --with-system-icu \
+ --with-system-icu \
+ --with-system-libpaper \
+ --with-system-libpng \
+ --with-system-pixman \
+ --with-system-poppler \
+ --with-system-xpdf \
+ --with-system-zlib \
+ --with-system-zziplib \
+ --without-texinfo \
|| return 1
make || return 1
}