aboutsummaryrefslogtreecommitdiffstats
path: root/testing/texlive
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-05-08 20:27:58 +0000
committerBreno Leitao <breno.leitao@gmail.com>2017-05-09 13:32:28 +0000
commit8a7ff854afc705a7c5dc1543d5fb7020dc34c686 (patch)
tree3afde335a1fa64c20c17c474495c7da09abda407 /testing/texlive
parent3ed47ea6d035ecf41a2bed8688db54295984a2cc (diff)
downloadaports-8a7ff854afc705a7c5dc1543d5fb7020dc34c686.tar.bz2
aports-8a7ff854afc705a7c5dc1543d5fb7020dc34c686.tar.xz
testing/texlive: Do not build luajittex on ppc64le
Currently texlive does not build on ppc64le due to building an embedded luajit from inside the texlive package. This luajit source does not contain ppc64le bits, thus, it FTBFS. Ideally, we would like to use system lua and luajit, but, the luajit build is instrinsics to current texlive building process. In this case, I am just removing luajittex on ppc64le.
Diffstat (limited to 'testing/texlive')
-rw-r--r--testing/texlive/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/testing/texlive/APKBUILD b/testing/texlive/APKBUILD
index 8e89c568e2..a8fb5f1993 100644
--- a/testing/texlive/APKBUILD
+++ b/testing/texlive/APKBUILD
@@ -26,6 +26,10 @@ _xetex="xelatex xelollipop"
build() {
cd "$builddir"
+ if [ "$CARCH" = "ppc64le" ] ; then
+ EXTRA="--disable-luajittex --disable-mfluajit"
+ fi
+
mkdir -p $builddir/build && cd $builddir/build
../configure -C \
--build=$CBUILD \
@@ -83,6 +87,7 @@ build() {
--with-system-zziplib \
--with-x-dvi-toolkit=motif \
--without-texinfo \
+ $EXTRA \
|| return 1
make || return 1
}