aboutsummaryrefslogtreecommitdiffstats
path: root/testing/watchman
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-08-09 16:33:17 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-08-24 23:15:27 +0000
commit79c6a348b179d8268bb327719f663aca560604ed (patch)
treee9176f2d6fb13fe4d021bec29d38d26f9ce2faf7 /testing/watchman
parent4fe25a54f65cca982baee1374d4383ca42754343 (diff)
downloadaports-79c6a348b179d8268bb327719f663aca560604ed.tar.bz2
aports-79c6a348b179d8268bb327719f663aca560604ed.tar.xz
testing/watchman: new aport
Diffstat (limited to 'testing/watchman')
-rw-r--r--testing/watchman/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/watchman/APKBUILD b/testing/watchman/APKBUILD
new file mode 100644
index 0000000000..f29265cb75
--- /dev/null
+++ b/testing/watchman/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=watchman
+pkgver=4.7.0
+pkgrel=0
+pkgdesc="A file watching service"
+url="https://facebook.github.io/watchman/"
+arch="all"
+license="Apache-2"
+makedepends="pcre-dev autoconf automake linux-headers"
+source="$pkgname-$pkgver.tar.gz::https://github.com/facebook/watchman/archive/v$pkgver.tar.gz"
+builddir="$srcdir/"$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./autogen.sh
+ ./configure --prefix= --exec-prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR=$pkgdir install-binPROGRAMS
+}
+
+sha512sums="1b0729bfba28948619ab910e0d21b8ff1392c3a4d1b39b77241e5465337d76ea54c51ad4a4b1458dd25ad231a3f4eb5c9fa68b3d6b0941f95f89ab80e8a4c0cb watchman-4.7.0.tar.gz"