aboutsummaryrefslogtreecommitdiffstats
path: root/testing/zsh-history-substring-search/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-23 00:00:31 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-23 00:00:54 +0200
commit4850969494cded669cc01318549093574c2ba7ca (patch)
tree8df05386a7a362e17ea99d11250242485261fbe4 /testing/zsh-history-substring-search/APKBUILD
parentd09edc41584c952bd1967250f4db190dee1882a8 (diff)
downloadaports-4850969494cded669cc01318549093574c2ba7ca.tar.bz2
aports-4850969494cded669cc01318549093574c2ba7ca.tar.xz
testing/zsh-history-substring-search: new aport
https://github.com/zsh-users/zsh-history-substring-search Zsh port of the Fish shell's history search
Diffstat (limited to 'testing/zsh-history-substring-search/APKBUILD')
-rw-r--r--testing/zsh-history-substring-search/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/zsh-history-substring-search/APKBUILD b/testing/zsh-history-substring-search/APKBUILD
new file mode 100644
index 0000000000..63c52adf0a
--- /dev/null
+++ b/testing/zsh-history-substring-search/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=zsh-history-substring-search
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="Zsh port of the Fish shell's history search"
+url="https://github.com/zsh-users/zsh-history-substring-search"
+arch="noarch"
+license="BSD"
+depends="zsh"
+source="$pkgname-$pkgver.tar.gz::https://github.com/zsh-users/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check" # upstream does not provide tests
+
+package() {
+ cd "$builddir"
+
+ install -D -m 644 $pkgname.zsh \
+ "$pkgdir"/usr/share/zsh/packages/$pkgname/$pkgname.zsh
+}
+
+sha512sums="0795befa068cedd46578960cf4102baafd182b69db598700c6361aebf17f64615972a981a5c4aad48318c45e9e9cd623d53956c704baa1b024cef9df83b138eb zsh-history-substring-search-1.0.1.tar.gz"