aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-02-14 03:31:51 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-14 03:31:51 +0000
commit06b1ad7230579cca99c76bf45618ab4b4fb57443 (patch)
tree902fd18d7f5b3569947b29ed122baa2e7b5f0daa /testing
parent1a9207fd7d1641d226ad7410d8ac6d4761b3f768 (diff)
downloadaports-06b1ad7230579cca99c76bf45618ab4b4fb57443.tar.bz2
aports-06b1ad7230579cca99c76bf45618ab4b4fb57443.tar.xz
testing/libucontext: use absolute LD_LIBRARY_PATH in testsuite
Diffstat (limited to 'testing')
-rw-r--r--testing/libucontext/0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch25
-rw-r--r--testing/libucontext/APKBUILD6
2 files changed, 29 insertions, 2 deletions
diff --git a/testing/libucontext/0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch b/testing/libucontext/0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch
new file mode 100644
index 0000000000..695501eb73
--- /dev/null
+++ b/testing/libucontext/0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch
@@ -0,0 +1,25 @@
+From 70089a405c006c6cae4480bd0307954983c48733 Mon Sep 17 00:00:00 2001
+From: William Pitcock <nenolod@dereferenced.org>
+Date: Wed, 14 Feb 2018 03:30:50 +0000
+Subject: [PATCH] build: use absolute path for LD_LIBRARY_PATH when testing
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index cc02c35..b524a2b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -40,7 +40,7 @@ install: all
+ ln -sf ${LIBUCONTEXT_SONAME} ${DESTDIR}/lib/${LIBUCONTEXT_NAME}
+
+ check: test_libucontext ${LIBUCONTEXT_SONAME}
+- env LD_LIBRARY_PATH=. ./test_libucontext
++ env LD_LIBRARY_PATH=$(shell pwd) ./test_libucontext
+
+ test_libucontext: test_libucontext.c ${LIBUCONTEXT_NAME}
+ $(CC) -std=c99 -D_BSD_SOURCE ${CFLAGS} ${CPPFLAGS} $@.c -o $@ ${LIBUCONTEXT_NAME}
+--
+2.16.1
+
diff --git a/testing/libucontext/APKBUILD b/testing/libucontext/APKBUILD
index 03d8adcdf5..0be415dc98 100644
--- a/testing/libucontext/APKBUILD
+++ b/testing/libucontext/APKBUILD
@@ -9,7 +9,8 @@ license="ISC"
depends=""
install=""
subpackages="$pkgname-dev"
-source="https://distfiles.dereferenced.org/libucontext/libucontext-$pkgver.tar.xz"
+source="https://distfiles.dereferenced.org/libucontext/libucontext-$pkgver.tar.xz
+ 0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch"
builddir="$srcdir/libucontext-$pkgver"
case "$CTARGET_ARCH" in
@@ -32,4 +33,5 @@ package() {
make ARCH="$LIBUCONTEXT_ARCH" DESTDIR="$pkgdir" install
}
-sha512sums="abeae370317c53e6656842edd619e87202865d8f8808808f5ec5dfd40c259dcdc3ee530e0227ae602ca255215cf472e99ad1e3fbbb54f362c5a3cf744d9a1be4 libucontext-0.1.0.tar.xz"
+sha512sums="abeae370317c53e6656842edd619e87202865d8f8808808f5ec5dfd40c259dcdc3ee530e0227ae602ca255215cf472e99ad1e3fbbb54f362c5a3cf744d9a1be4 libucontext-0.1.0.tar.xz
+26e1933e822ddc83086295144e5e8dc09602ad9200703b0e8c832bee0ee335c62c758d9847058bb28baf248f825d00604cfa1b4cb9b48234760c0e92cafb296a 0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch"