aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-02-14 03:23:53 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-14 03:24:20 +0000
commit16e7c1b30c509e5be936ae4c5311fad0e95b8798 (patch)
tree0512ebd286de5dad061e62e5a0bd7b25d6ba0ae4 /testing
parentcdb9aca8c637ff6b70547f8588e23bf23e83d576 (diff)
downloadaports-16e7c1b30c509e5be936ae4c5311fad0e95b8798.tar.bz2
aports-16e7c1b30c509e5be936ae4c5311fad0e95b8798.tar.xz
testing/libucontext: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/libucontext/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/libucontext/APKBUILD b/testing/libucontext/APKBUILD
new file mode 100644
index 0000000000..03d8adcdf5
--- /dev/null
+++ b/testing/libucontext/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=libucontext
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="ucontext function implementations"
+url="http://github.com/kaniini/libucontext"
+arch="all !s390x"
+license="ISC"
+depends=""
+install=""
+subpackages="$pkgname-dev"
+source="https://distfiles.dereferenced.org/libucontext/libucontext-$pkgver.tar.xz"
+builddir="$srcdir/libucontext-$pkgver"
+
+case "$CTARGET_ARCH" in
+ppc64le) LIBUCONTEXT_ARCH="ppc64" ;;
+*) LIBUCONTEXT_ARCH="$CTARGET_ARCH" ;;
+esac
+
+build() {
+ cd "$builddir"
+ make ARCH="$LIBUCONTEXT_ARCH"
+}
+
+check() {
+ cd "$builddir"
+ make ARCH="$LIBUCONTEXT_ARCH" check
+}
+
+package() {
+ cd "$builddir"
+ make ARCH="$LIBUCONTEXT_ARCH" DESTDIR="$pkgdir" install
+}
+
+sha512sums="abeae370317c53e6656842edd619e87202865d8f8808808f5ec5dfd40c259dcdc3ee530e0227ae602ca255215cf472e99ad1e3fbbb54f362c5a3cf744d9a1be4 libucontext-0.1.0.tar.xz"