aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2012-12-05 16:33:06 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2012-12-05 16:33:06 +0100
commit16e9aadcd9de2fdf968673d2b2343f40f988ac8e (patch)
tree88785f690231132fad7351effc4b76802264723d /testing
parentebecc46bd4ef29ab3cb54c197325bf6ffee6b8a4 (diff)
downloadaports-16e9aadcd9de2fdf968673d2b2343f40f988ac8e.tar.bz2
aports-16e9aadcd9de2fdf968673d2b2343f40f988ac8e.tar.xz
testing/crystalhd-git-grsec: renamed and new snapshot
Diffstat (limited to 'testing')
-rw-r--r--testing/crystalhd-git-grsec/APKBUILD (renamed from testing/crystalhd-git/APKBUILD)35
-rw-r--r--testing/crystalhd-git-grsec/crystalhd-use_8_DMA_buffers-0.1.patch (renamed from testing/crystalhd-git/crystalhd-use_8_DMA_buffers-0.1.patch)0
2 files changed, 18 insertions, 17 deletions
diff --git a/testing/crystalhd-git/APKBUILD b/testing/crystalhd-git-grsec/APKBUILD
index 25116af399..82b1e6da54 100644
--- a/testing/crystalhd-git/APKBUILD
+++ b/testing/crystalhd-git-grsec/APKBUILD
@@ -7,7 +7,7 @@ _name=$_realname-$_flavor
_kpkg=linux-$_flavor
_kver=3.6.9
-_kpkgrel=0
+_kpkgrel=1
_mypkgrel=0
_date=20121126
@@ -23,7 +23,7 @@ _kernelver=$_kver-r$_kpkgrel
_abi_release=$_kver-${_flavor}
pkgname=$_name
-pkgver=$_kver
+pkgver=20121205
pkgrel=$(($_kpkgrel + $_mypkgrel))
pkgdesc="Broadcom CrystalHD kernel driver"
url="http://git.linuxtv.org/jarod/crystalhd.git"
@@ -44,21 +44,22 @@ _kerdir="$srcdir/$pkgname-$_date/driver/linux"
_builddir="$srcdir/$pkgname-$_date"
snapshot() {
- _date=$(date +%Y%m%d)
- local _pkg=$pkgname-$_date.tar.gz
- mkdir -p "$srcdir"
- cd "$srcdir"
- ls -alh
- rm -rf crystalhd.git
- git clone --depth=1 --bare $_giturl || return 1
- git --git-dir ${_giturl##*/} archive -o $_pkg \
- --prefix=$pkgname-$_date/ HEAD \
- || return 1
- msg "New snapshot: $_pkg"
- msg "Uploading to $_upload"
- rsync -ave ssh $_pkg $_upload || return 1
- cd ..
- sed -i -e "s/^_date=.*/_date=$_date/" APKBUILD || return 1
+ local _date=$(date +%Y%m%d)
+ local _pkg=$pkgname-$_date.tar.gz
+ mkdir -p "$srcdir"
+ cd "$srcdir"
+ msg "Creating snapshot: $_pkg"
+ rm -rf ${_giturl##*/}
+ git clone --depth=1 --bare $_giturl || return 1
+ git --git-dir ${_giturl##*/} archive -o $_pkg \
+ --prefix=$pkgname-$_date/ HEAD \
+ || return 1
+ msg "Uploading to $_upload"
+ rsync -Lave ssh $_pkg $_upload || return 1
+ cd "$startdir"
+ sed -i -e "s/^pkgver=.*/pkgver=$_date/" \
+ APKBUILD || return 1
+ abuild checksum
}
prepare() {
diff --git a/testing/crystalhd-git/crystalhd-use_8_DMA_buffers-0.1.patch b/testing/crystalhd-git-grsec/crystalhd-use_8_DMA_buffers-0.1.patch
index 1b9150ea7b..1b9150ea7b 100644
--- a/testing/crystalhd-git/crystalhd-use_8_DMA_buffers-0.1.patch
+++ b/testing/crystalhd-git-grsec/crystalhd-use_8_DMA_buffers-0.1.patch