aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-05-06 11:11:40 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-05-06 11:11:40 -0500
commit48175a08dd23f4a81079e2c691eefaca0b593de4 (patch)
tree890cb61c322a98d02c647c38ca50b577d6597c86 /testing
parent8518325480d4d17deeb24c76a82fbdfb820c5942 (diff)
downloadaports-48175a08dd23f4a81079e2c691eefaca0b593de4.tar.bz2
aports-48175a08dd23f4a81079e2c691eefaca0b593de4.tar.xz
testing/xf86-video-nouveau: update git snapshot
Diffstat (limited to 'testing')
-rw-r--r--testing/xf86-video-nouveau/APKBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/testing/xf86-video-nouveau/APKBUILD b/testing/xf86-video-nouveau/APKBUILD
index 518a519982..afb46d00a9 100644
--- a/testing/xf86-video-nouveau/APKBUILD
+++ b/testing/xf86-video-nouveau/APKBUILD
@@ -1,8 +1,9 @@
# Contributor:
# Maintainer:
pkgname=xf86-video-nouveau
-pkgver=0.0.16
-pkgrel=0
+_gitdate=20110506
+pkgver=0.0.16_git${_gitdate}
+pkgrel=1
pkgdesc="Open-source X.org drivers for nVidia video cards"
url="http://nouveau.freedesktop.org/"
arch="all"
@@ -12,9 +13,17 @@ depends_dev=
makedepends="pkgconfig randrproto renderproto videoproto xextproto libdrm-dev xorg-server-dev util-macros libtool autoconf automake xf86driproto"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://ftp.de.debian.org/debian/pool/main/x/xserver-xorg-video-nouveau/xserver-xorg-video-nouveau_$pkgver+git20101210+8bb8231.orig.tar.gz"
+source="http://dev.alpinelinux.org/~nenolod/xf86-video-nouveau-${_gitdate}.tar.bz2"
-_builddir="$srcdir/$pkgname"
+_builddir="${srcdir}/${pkgname}-${_gitdate}"
+
+mksource() {
+ mkdir /tmp/${pkgname}-${_gitdate}
+ (cd /tmp/${pkgname}-${_gitdate};
+ git clone -v --depth 1 git://anongit.freedesktop.org/nouveau/xf86-video-nouveau;
+ cd xf86-video-nouveau;
+ git archive --prefix=xf86-video-nouveau-${_gitdate}/ --format=tar HEAD | bzip2 > /tmp/${pkgname}-${_gitdate}/${pkgname}-${_gitdate}.tar.bz2)
+}
build() {
cd "$_builddir"
@@ -27,4 +36,4 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="65067b46401f385ba833130d634fe319 xserver-xorg-video-nouveau_0.0.16+git20101210+8bb8231.orig.tar.gz"
+md5sums="f48ffca3436988f5ffe915d7b47192a9 xf86-video-nouveau-20110506.tar.bz2"