aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-03-03 19:19:00 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-03-04 19:21:40 +0000
commit6a641061d0b129c0f97805abcb304a48f554b531 (patch)
tree07f0f7ef32f81ec0c2a76f60a11caaae7d3db90c /testing
parent4c8b8461243b2b6bf7ba968b580b935f5709992a (diff)
downloadaports-6a641061d0b129c0f97805abcb304a48f554b531.tar.bz2
aports-6a641061d0b129c0f97805abcb304a48f554b531.tar.xz
testing/wireguard-vanilla: fix $install_if / remove make check
make check removed at the request of the author
Diffstat (limited to 'testing')
-rw-r--r--testing/wireguard-vanilla/APKBUILD17
1 files changed, 4 insertions, 13 deletions
diff --git a/testing/wireguard-vanilla/APKBUILD b/testing/wireguard-vanilla/APKBUILD
index 812f9ad951..40094954d5 100644
--- a/testing/wireguard-vanilla/APKBUILD
+++ b/testing/wireguard-vanilla/APKBUILD
@@ -8,7 +8,7 @@ _kpkgrel=0
# when changing _ver we *must* bump _mypkgrel
_ver=0.0.20170223
-_mypkgrel=0
+_mypkgrel=1
_name=wireguard
# verify the kernel version before entering chroot
@@ -30,7 +30,9 @@ pkgdesc="Next generation secure network tunnel: kernel modules for $_flavor"
arch='all'
url='https://www.wireguard.io'
license="GPLv2"
-makedepends="linux-vanilla-dev=$_kpkgver libmnl-dev sparse"
+makedepends="linux-vanilla-dev=$_kpkgver libmnl-dev"
+install_if="wireguard-tools linux-vanilla-$_kver"
+options="!check"
source="https://git.zx2c4.com/WireGuard/snapshot/WireGuard-$_ver.tar.xz"
builddir="$srcdir"/WireGuard-$_ver
@@ -45,7 +47,6 @@ build() {
package() {
cd "$builddir/src"
- install_if="linux-${_flavor}=${_kver} $pkgname"
local module=
for module in *.ko; do
@@ -54,14 +55,4 @@ package() {
done
}
-check() {
- return 0
- # currently failing: attribute 'nocapture': unknown attribute
- # not part of musl libc ?
- make -C src/ \
- KERNELDIR=/lib/modules/${_abi_release}/build \
- check \
- || return 1
-}
-
sha512sums="273ef6463d447cb04b608a0379cce5c0ed4065f988b3f449995593592b42f2fc269fc249a8e3c22c28bfa682430ee20b5b7a46a96803c9c67d1b6fed7b800455 WireGuard-0.0.20170223.tar.xz"