aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-12 19:46:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-12 19:46:06 +0000
commit885065fae0e085ec41befcffd01bc6512607dc10 (patch)
tree37d3c88f9e4903d3fa26de7b51ec9d722081003e /testing
parent947b4d4e384615dd605b6b66ebc01f2661a39c17 (diff)
downloadaports-885065fae0e085ec41befcffd01bc6512607dc10.tar.bz2
aports-885065fae0e085ec41befcffd01bc6512607dc10.tar.xz
testing/linux-tools: fix build by disable -Werror
Diffstat (limited to 'testing')
-rw-r--r--testing/linux-tools/APKBUILD6
-rw-r--r--testing/linux-tools/disable-Werror.patch13
2 files changed, 17 insertions, 2 deletions
diff --git a/testing/linux-tools/APKBUILD b/testing/linux-tools/APKBUILD
index 1684179518..1a34291636 100644
--- a/testing/linux-tools/APKBUILD
+++ b/testing/linux-tools/APKBUILD
@@ -11,12 +11,13 @@ license="GPL-2.0-only"
depends="cpupower perf"
depends_dev="pciutils-dev readline-dev gettext-dev"
makedepends="$depends_dev elfutils-dev bash linux-headers flex bison diffutils
- zlib-dev"
+ zlib-dev findutils"
install=""
subpackages="perf perf-bash-completions:perf_completions cpupower $pkgname-doc $pkgname-dev"
source="https://kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
https://kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
cpupower-libs.patch
+ disable-Werror.patch
"
builddir="$srcdir"/linux-$_kernver
@@ -83,4 +84,5 @@ perf_completions() {
sha512sums="950eb85ac743b291afe9f21cd174d823e25f11883ee62cecfbfff8fe8c5672aae707654b1b8f29a133b1f2e3529e63b9f7fba4c45d6dacccc8000b3a9a9ae038 linux-4.18.tar.xz
169c232c1799eae10b5fa399fc2cb0567536681e8e17f59fe0c489c6186d368261ba45baf1b6f71a0d111895cbf4a44d93f7ee3e20d4842b699f75f5372c8d38 patch-4.18.13.xz
-a46e3a84b00a39a356618831d0ddfb7f0d10f0a3799d1307ba2cc832e73c01f8d637a4e801a6dd25025f6f13155c6ad8b836422ff72d365e51063ac0bf907f52 cpupower-libs.patch"
+a46e3a84b00a39a356618831d0ddfb7f0d10f0a3799d1307ba2cc832e73c01f8d637a4e801a6dd25025f6f13155c6ad8b836422ff72d365e51063ac0bf907f52 cpupower-libs.patch
+a0b90cead5f80a7e785b2fdd8ac9faed1234f4aa5eebf658af8d8b4d3b8593147ff43810d0b28a95b057bb7781113a48723b9cf9432ec8d9510451b51416e3de disable-Werror.patch"
diff --git a/testing/linux-tools/disable-Werror.patch b/testing/linux-tools/disable-Werror.patch
new file mode 100644
index 0000000000..e543d958ca
--- /dev/null
+++ b/testing/linux-tools/disable-Werror.patch
@@ -0,0 +1,13 @@
+diff --git a/tools/lib/bpf/Makefile b/tools/lib/bpf/Makefile
+index 5390e77..b9b4bb7 100644
+--- a/tools/lib/bpf/Makefile
++++ b/tools/lib/bpf/Makefile
+@@ -122,7 +122,7 @@ endif
+
+ # Append required CFLAGS
+ override CFLAGS += $(EXTRA_WARNINGS)
+-override CFLAGS += -Werror -Wall
++override CFLAGS += -Wall
+ override CFLAGS += -fPIC
+ override CFLAGS += $(INCLUDES)
+