aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 04:19:49 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 04:19:49 +0000
commit9a9a043ef5fe2314ccc7c4d64dc0729e39e4e2b2 (patch)
tree4085d8d5b1d9261f1a60d86727987766f8ce2e9d /testing
parent36a0a499fd5fdf0d92f522d36559c4be8c4eb514 (diff)
downloadaports-9a9a043ef5fe2314ccc7c4d64dc0729e39e4e2b2.tar.bz2
aports-9a9a043ef5fe2314ccc7c4d64dc0729e39e4e2b2.tar.xz
testing/py-jsonpickle: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/py-jsonpickle/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py-jsonpickle/APKBUILD b/testing/py-jsonpickle/APKBUILD
new file mode 100644
index 0000000000..07af26c684
--- /dev/null
+++ b/testing/py-jsonpickle/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py-jsonpickle
+pkgver=0.9.5
+pkgrel=0
+pkgdesc="an jsonpickle implementation"
+url="https://pypi.python.org/pypi/jsonpickle/"
+arch="noarch"
+license="BSD"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-jsonpickle:py2 py3-jsonpickle:py3"
+source="https://files.pythonhosted.org/packages/source/j/jsonpickle/jsonpickle-$pkgver.tar.gz"
+builddir="$srcdir/jsonpickle-$pkgver"
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ cd "$builddir"
+ _py python2
+}
+
+py3() {
+ cd "$builddir"
+ _py python3
+}
+
+sha512sums="4fd3a61a08c149ccce578c78c4f3117546f58819a1015f9d8fc794c84af9b882e77905ca42a12b1f9716e2652fc4e959a85d3aee3b937be687bd5a9abe8859e2 jsonpickle-0.9.5.tar.gz"