aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-17 20:46:17 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-17 20:46:56 +0100
commit9c02765c70f461cbf77c4ba35a294b53894a52d0 (patch)
tree04815a10ca730262035965080c17469559c574e1 /testing
parentfca60d7c73c8a8634fbb3a4df739ecb9dc8f0350 (diff)
downloadaports-9c02765c70f461cbf77c4ba35a294b53894a52d0.tar.bz2
aports-9c02765c70f461cbf77c4ba35a294b53894a52d0.tar.xz
testing/gomplate: add check() function
Diffstat (limited to 'testing')
-rw-r--r--testing/gomplate/APKBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/testing/gomplate/APKBUILD b/testing/gomplate/APKBUILD
index cbdf3bd7f5..e4d64d6fed 100644
--- a/testing/gomplate/APKBUILD
+++ b/testing/gomplate/APKBUILD
@@ -27,6 +27,15 @@ build() {
COMMIT="unknown"
}
+check() {
+ cd "$builddir"
+
+ # Note: make test (that runs go test -race) doesn't work.
+ GOPATH="$srcdir" go test -v || return 1
+
+ ./bin/gomplate --help >/dev/null
+}
+
package() {
cd "$builddir"
install -D -m 755 bin/gomplate "$pkgdir"/usr/bin/gomplate || return 1