aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-17 14:04:29 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-17 14:04:45 +0200
commitaad10a0366373502b783839722c2b4f7feb8a881 (patch)
tree0130f78e401805bf93a89c85111e210422db73f6 /testing
parentb801a6e1ec026da0051a42f8b55ef8572c2638cc (diff)
downloadaports-aad10a0366373502b783839722c2b4f7feb8a881.tar.bz2
aports-aad10a0366373502b783839722c2b4f7feb8a881.tar.xz
testing/acme-client-plus: new aport
https://github.com/jirutka/acme-client-plus Script for periodic renewal of certificates using BSD's acme-client
Diffstat (limited to 'testing')
-rw-r--r--testing/acme-client-plus/APKBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/testing/acme-client-plus/APKBUILD b/testing/acme-client-plus/APKBUILD
new file mode 100644
index 0000000000..91278f1fa7
--- /dev/null
+++ b/testing/acme-client-plus/APKBUILD
@@ -0,0 +1,20 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=acme-client-plus
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Script for periodic renewal of certificates using BSD's acme-client"
+url="https://github.com/jirutka/acme-client-plus"
+arch="noarch"
+license="ISC"
+depends="acme-client libressl"
+options="!check" # no tests provided
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" prefix=/usr
+}
+
+sha512sums="589a475e770ea1f1f590002dcae39534f91d1840b4f09930b17caa5ebceb7acac9b1b8843acd254ad997747e19118db3d53d3a805db89c59d3327e9ae7effcd7 acme-client-plus-0.1.0.tar.gz"