aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-13 22:03:41 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-13 22:03:41 +0200
commite7d1ffb47731c2ee3cd4bab29dd46c94265e2f96 (patch)
tree500043d4a043b8f65939a81c106491740d8b6873 /testing
parent8569731b43ddbc3803f34965bbdeab2322425cde (diff)
downloadaports-e7d1ffb47731c2ee3cd4bab29dd46c94265e2f96.tar.bz2
aports-e7d1ffb47731c2ee3cd4bab29dd46c94265e2f96.tar.xz
Revert "community/libcoap: move from testing"
Diffstat (limited to 'testing')
-rw-r--r--testing/libcoap/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/testing/libcoap/APKBUILD b/testing/libcoap/APKBUILD
new file mode 100644
index 0000000000..68906089c5
--- /dev/null
+++ b/testing/libcoap/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=libcoap
+pkgver=4.1.2
+pkgrel=0
+pkgdesc="A CoAP (RFC 7252) implementation"
+url="https://github.com/obgm/libcoap"
+arch="all"
+license="BSD GPL2+"
+depends=""
+depends_dev=""
+makedepends="automake autoconf libtool asciidoc"
+checkdepends="cunit-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/obgm/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ ./autogen.sh
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-tests
+ make
+}
+
+check() {
+ "$builddir"/tests/testdriver
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname
+ install -m644 CONTRIBUTE AUTHORS ChangeLog NEWS README.md TODO \
+ "$pkgdir"/usr/share/doc/$pkgname
+}
+
+sha512sums="151f40cdacddf25bdffe367b4f1e3bf295445eac966db7bcf6692047cd9d5476b726f08c8d1de7dbe4ebe2477162b4df5e6c121e24eac79f9a4041ab2a646be6 libcoap-4.1.2.tar.gz"