aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-08-01 13:58:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-01 14:08:43 +0000
commit0884190918f47872a45bcf231b9b04db18a96bd6 (patch)
tree8a5ec5f06ea9147dfbc98a2ac3c766deb67898aa /testing
parentb0e2f7183d57ca7aae58b6bcbd6dd5fa30ede327 (diff)
downloadaports-0884190918f47872a45bcf231b9b04db18a96bd6.tar.bz2
aports-0884190918f47872a45bcf231b9b04db18a96bd6.tar.xz
testing/aports-ghpr: use go dep to solve dependencies
Diffstat (limited to 'testing')
-rw-r--r--testing/aports-ghpr/APKBUILD21
-rw-r--r--testing/aports-ghpr/add-toml-file.patch6
2 files changed, 19 insertions, 8 deletions
diff --git a/testing/aports-ghpr/APKBUILD b/testing/aports-ghpr/APKBUILD
index 4e30824fec..402290ad34 100644
--- a/testing/aports-ghpr/APKBUILD
+++ b/testing/aports-ghpr/APKBUILD
@@ -1,22 +1,26 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=aports-ghpr
pkgver=0.1
-pkgrel=0
+pkgrel=1
pkgdesc="Search aport in github pull requests"
url="http://git.alpinelinux.org/cgit/user/ncopa/aports-ghpr"
arch="all"
license="ISC"
-makedepends="go glide"
-source="http://dev.alpinelinux.org/archive/aports-ghpr/aports-ghpr-$pkgver.tar.xz"
-builddir="$srcdir/aports-ghpr-$pkgver"
+makedepends="go dep"
+source="http://dev.alpinelinux.org/archive/aports-ghpr/aports-ghpr-$pkgver.tar.xz
+ add-toml-file.patch"
+builddir="$srcdir/src/github.com/aports-ghpr/$pkgname"
options="!check"
+prepare() {
+ mkdir -p ${builddir%/*}
+ mv "$srcdir/$pkgname-$pkgver" "$builddir/"
+ default_prepare
+}
build() {
cd "$builddir"
export GOPATH="$srcdir"
-
- # I guess this is wrong way to get dependencies but i dont know how?
- go get -v github.com/google/go-github/github
+ dep ensure -v
make
}
@@ -25,4 +29,5 @@ package() {
make DESTDIR="$pkgdir" prefix=/usr install
}
-sha512sums="3351b2b18e88c064b63061c107e92a8d7c8c42bf0e265278b960af1ab3f848c584ced291b4f8e9845ad654d058345fc730751e161038dee0cea421cd117e2814 aports-ghpr-0.1.tar.xz"
+sha512sums="3351b2b18e88c064b63061c107e92a8d7c8c42bf0e265278b960af1ab3f848c584ced291b4f8e9845ad654d058345fc730751e161038dee0cea421cd117e2814 aports-ghpr-0.1.tar.xz
+ce320bee6eb10f5b80a7dba7124d17437ac6b21a53bff29a7fd2022399312543322a5102a61f2c63b8fadc12c52ed517bf1289a0f97cdd18435db56bdfd75695 add-toml-file.patch"
diff --git a/testing/aports-ghpr/add-toml-file.patch b/testing/aports-ghpr/add-toml-file.patch
new file mode 100644
index 0000000000..cce11685ff
--- /dev/null
+++ b/testing/aports-ghpr/add-toml-file.patch
@@ -0,0 +1,6 @@
+--- /dev/null
++++ src/Gopkg.toml
+@@ -0,0 +1,3 @@
++[[constraint]]
++ name = "github.com/google/go-github"
++ version = "15.0.0"