aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-05-30 15:26:52 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-05-30 19:07:49 +0200
commit1f5334267557276385e659fecd20af4576a56661 (patch)
tree856618e263f10ee84d9f2e22376ea07639de48e8 /testing
parent0907dbd56ac5acea50f08cfad61ace2a46047696 (diff)
downloadaports-1f5334267557276385e659fecd20af4576a56661.tar.bz2
aports-1f5334267557276385e659fecd20af4576a56661.tar.xz
testing/z3: add check
Diffstat (limited to 'testing')
-rw-r--r--testing/z3/APKBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/testing/z3/APKBUILD b/testing/z3/APKBUILD
index a7cdf18c5b..be5ab3f785 100644
--- a/testing/z3/APKBUILD
+++ b/testing/z3/APKBUILD
@@ -29,6 +29,14 @@ build() {
-DCMAKE_C_FLAGS="$CFLAGS" \
..
make
+
+ # Binary for running the unit tests
+ make test-z3
+}
+
+check() {
+ cd "$builddir"
+ ./build/test-z3 -a
}
package() {